Cannot edit external Collabora documents on hidden user share

Nextcloud version: 16.0.1 RC 1
Operating system and version: 18.04.1
Apache or nginx version: 2.4.29
PHP version: 7.2.17
Collabora version: 6.0

The issue you are facing:
Cannot open a Collabora document on SMB external storage.
Works normally with internally stored documents.
Worked both ways on NC 15
External share authentication is currently set to use Log-in credentials, save in database.

EDIT
I just realized this only happens on a hidden share (our user folders) with username variable ($user)
For example:
\\server\user_shares$\$user

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Open Collabora document on hidden external smb share with username variable in path.

The output of your Nextcloud log in Admin > Logging:

[PHP] Error: Undefined offset: 0 at /var/www/nextcloud/apps/richdocuments/lib/Controller/WopiController.php#132

GET /index.php/apps/richdocuments/wopi/files/xxxx?access_token=xxxx
access_token_ttl=0&permission=edit
from x.x.x.x at 2019-05-09T19:23:11+00:00

I’m guess this is a conflict at line 132?

$file = $userFolder->getById($fileId)[0];
1 Like

Seems to be related to this:

1 Like

Can confirm this bug.

Only happening if hidden user share ($user) is used.
You can see and access the hidden user share without problems, but it’s not possible to open files within the usershare in Collabora.

There is a workaround for using the hidden SMB-shares again, but I cant find any solution for this problem.
Just to mention: I am no programmer and I cant find any code that I can adjust ( like the workaround for the first not working hidden SMB-shares).

EDIT:
1.) Opening normal hidden shares is working. Only shares that contain “$user”-parameter are affected.

2.) I did the workaround that NextCloudJay mentioned

3.) I am using the actual docker version of Collabora:
4.0.4
Collabora Office 6.0-29
and the up2date version of the Nextcloud-Collabora-App ( Collabora Online 3.3.6)

Any update regarding this bug?

hmm I have this issue too, though not with Collabora (not using it yet), but with just mounting student home directories. This works in Owncloud which, it looks like, I’ll have to stick with for the time being.