Cannot create, move, rename or delete files from external local storage

Hardware: Beelink U59
YunoHost version: (stable)
**I have access to my server : Through SSH & through the webadmin & direct access via keyboard / screen
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes, runing backports package because my GPU is not available with Debian 10, so I upgraded kernel of linux in 5.X Backports and forced it in the grub to launch the GPU pilots.
Nextcloud version (eg, 20.0.5): 22.2.0
Operating system and version (eg, Ubuntu 20.04): Debian 10
Apache or nginx version (eg, Apache 2.4.25): 1.14.2
PHP version (eg, 7.4): 7.3

The issue you are facing:
My goal is to create a hoster cloud server through nextcloud. I have mounted a NAS in the fstab and have full read and write access to all the folders on the NAS from the computer.

So I subsequently installed Nextcloud, add the NAS to external media, but I cannot create, move, upload, a file. Only read access is allowed to me.
I tried a chmod 777, chown … and nothing helps.
Here is what I get when I try an action :

It seems that the permissions are not the same between the local yunohost folder for which everything is working fine and the connection to nas as external storage:

root @ cyragroup: / home / bencg # ls -al /home/
total 12
drwxrwxrwx 3 root root 4096 Dec 10 15:44.
drwxr-xr-x 3 root root 4096 Nov 9 15:38 ..
drwxr-x --- 9 nextcloud nextcloud 4096 Nov 12 12:53 data
root @ cyragroup: / home / bencg # ls -al / media / nas
total 2624
drwxr-xr-x 2 bencg bencg 0 Dec 10 15:07.
drwxr-xr-x 6 root root 4096 Dec 10 13:49 ..
drwxr-xr-x 2 bencg bencg 0 Jan 2 2015 '01_ARCHITECTURE POST PRODUCTION'
drwxr-xr-x 2 bencg bencg 0 Dec 10 15:18 02_LIBRARY
drwxr-xr-x 2 bencg bencg 0 Oct 18 09:49 03_STOCK_RC

But impossible to change that with chown and chmod …

I’m out of ideas,

Thank you in advance for your help,
Good day,

Is this the first time you’ve seen this error? (Y/N): YES

Steps to replicate it:

  1. Connect
  2. Go to the external storage
  3. Create a file

The output of your Nextcloud log in Admin > Logging:

Does not show my problem…

Problem solved, it was due to bad gid uid in the fstab file.

1 Like