Cannot connect via SSL (CalDav/CardDav) - only for one user


I am new to Nextcloud, just installed it on my Synology NAS about a week ago using the Webstation package. I use a DDNS domain which points to my external IP. On my Diskstation I added a name based virtual host and then a Let’s encrypt certificate for that.
Everything was working so far - I added my Calendar on my iPhone through the CalDAV function and my addressbook, too. No problems.

Today I also wanted to add my Calendar to my iPad but am facing the problem that it cannot be added because it cannot connect via SSL. This is strange. I then tried it on my iPhone again, no luck, same problem - although it worked some days before and I haven’t changed anything intentionally. The SSL certificate is still valid.

The interesting thing is: It seems to affect only my account which happens to be the admin account. If I try to add the Calendar of my girlfriend’s account on my iPad oder my iPhone, everything is working as expected. No problem, no error.

In addition: When I try to login with my account I very often get an 504 time out error whereas if directly afterwards login with a different account, there are no problems and no error.

Do you have any ideas what the problem with my account could be. I don’t get any warnings in Nextcloud.

Thank you in advance!

Is there a way to reset my user account maybe? There seems to be a problem that is exclusive to my account… no idea what or why