Cannot add external storage


I’ve setup a nextcloud server and I’m having trouble with external storage.
I’ve installed the “External Storage” app and I’ve tried configuring it, but no matter what I try, I can’t seem to make it work.
I’ve created a folder called “backup” in the root of the external HDD, changed the owner+group to www-data and changed the permissions to 750.
Here’s what I’ve tried:

  1. I set the path/configuration (from External Storages) to /media/username/hdd name/backup.
    I got the exclamation mark in the red dot. No error message or any indication of what the problem might be.
  2. I unmounted the drive and remounted it in /media/hdd_name and set the path/configuration to /media/hdd_name/backup.
    Still didn’t work. Exclamation mark in red dot again. No error message.
  3. I set the path/configuration to /media/hdd name.
    I got the green checkmark. But when I go to External Storages in Files and click the “backup” folder, I’m taken back to the Files page.

Frankly, I’m out of ideas. Can anyone please help?
Thank you.

My setup is:

Nextcloud 18.0.3
Mac Mini (late 2014), Intel® Core™ i5-4260U, 4GB RAM
Ubuntu 18.04 (not Mac OS)
Apache2 Web Server
PHP 7.2
External drive is a 1TB WD HDD encased in a rack (it’s actually an internal HDD, not an external one), formatted as ext4