Cannot add circles nor groups nor users under Deck app to a board

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 22.1.0
Operating system and version (eg, Ubuntu 20.04): 20.04
Apache or nginx version (eg, Apache 2.4.25): 2.4.41
PHP version (eg, 7.4): 7.4

The issue you are facing:
I cant add users nor circles under the Deck app.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Go to Deck
  2. Load Board
  3. Go to the Board’s sharing/option
  4. The search bar has a looping circle like searching but whatever i type (user,group or circle it doesnt show up.

The output of your Nextcloud log in Admin > Logging:

[no app in context] Error: in_array() expects parameter 2 to be array, null given

GET /ocs/v2.php/apps/files_sharing/api/v1/sharees?search=&format=json&perPage=20&itemType=0%2C1%2C4%2C7&lookup=false
from <IP> by monark at 2021-08-20T03:05:59+00:00

{"reqId":"1hFJC1ZsTZuPxXjkNIu4","level":3,"time":"2021-08-20T03:05:59+00:00","remoteAddr":"<IP>","user":"monark","app":"no app in context","method":"GET","url":"/ocs/v2.php/apps/files_sharing/api/v1/sharees?search=&format=json&perPage=20&itemType=0%2C1%2C4%2C7&lookup=false","message":"in_array() expects parameter 2 to be array, null given","userAgent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.131 Safari/537.36 Edg/92.0.902.73","version":"","exception":{"Exception":"Exception","Message":"in_array() expects parameter 2 to be array, null given","Code":0,"Trace":[{"file":"/var/www/","line":156,"function":"dispatch","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->"},{"file":"/var/www/","line":301,"function":"main","class":"OC\\AppFramework\\App","type":"::"},{"file":"/var/www/","line":62,"function":"match","class":"OC\\Route\\Router","type":"->"},{"file":"/var/www/","line":23,"args":["/var/www/"],"function":"require_once"}],"File":"/var/www/","Line":158,"Previous":{"Exception":"TypeError","Message":"in_array() expects parameter 2 to be array, null given","Code":0,"Trace":[{"file":"/var/www/","line":101,"function":"in_array"},{"file":"/var/www/","line":72,"function":"search","class":"OCA\\Circles\\Collaboration\\v2\\CollaboratorSearchPlugin","type":"->"},{"file":"/var/www/","line":228,"function":"search","class":"OC\\Collaboration\\Collaborators\\Search","type":"->"},{"file":"/var/www/","line":217,"function":"search","class":"OCA\\Files_Sharing\\Controller\\ShareesAPIController","type":"->"},{"file":"/var/www/","line":126,"function":"executeController","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->"},{"file":"/var/www/","line":156,"function":"dispatch","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->"},{"file":"/var/www/","line":301,"function":"main","class":"OC\\AppFramework\\App","type":"::"},{"file":"/var/www/","line":62,"function":"match","class":"OC\\Route\\Router","type":"->"},{"file":"/var/www/","line":23,"args":["/var/www/"],"function":"require_once"}],"File":"/var/www/","Line":101},"CustomMessage":"--"},"id":"611f1c6082cca"}

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


The output of your Apache/nginx/system log in /var/log/____:



1 Like

I think it mught be. I also tried using the “Talk” app and i have the same error, so it is a Circles app bug. Thank you

Same here! Please fix soon, it is unusable otherwise!

1 Like

Based on the comment above about the issue being related to a Circles bug I’ve disabled circles and can now share a “List” on the Deck.

1 Like

Can concur. This worked. I’d like to try out the circles functionality, but this at least gets deck working again.