Cannot access my nextcloud server after moving house

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 18.0.2): 18.xx
Operating system and version (eg, Ubuntu 20.04): linux mint 19.3
Apache or nginx version (eg, Apache 2.4.25): apache 2.4.29
PHP version (eg, 7.1): 7.2

The issue you are facing:

so i have a dedicated computer running linux mint 19.3 set up as LAMP stack and was running only nextcloud. i had it connected to the modem via a cable and given an ip=192.168.0.XX. ports 80 and 443 were forwarded from the modem. also no-ip’s DUC was running because my external ip was not static.

Last weekend i moved house and now i have new internet and new modem and i configured the modem exactly as the old one giving the same local ip to the computer using WIFI this time. updated my dns to point to the new external ip but i can’t access my nextcloud. What am i missing?

Is this the first time you’ve seen this error? (Y/N): y

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


The output of your Apache/nginx/system log in /var/log/____:


Here are my thoughts:

  • It might be possible that the wifi dhcp range of your router is a different network than the one of your lan.
  • It might be possible that your router provides an internal and a guest wifi and you’re connection to the wrong network.
  • It might be possible that you have enabled a kind of privacy separation for your wifi network which don’t allows wifi clients to see each other.

thanks for the insight. There is only one modem which both the computers are connected to. i am able to ping and ssh into my LAMP using its local ip and the ip range is also the same as before. 192.168.0.xx. and when i enter that ip it takes me to the apache2 default page in the browser.

If you’re able to reach your server using a web browser, you most likely don’t have a connection problem. You haven’t described in detail how you’ve set-up your Nextcloud. So please provide DETAILED information how you’ve previously accessed it, how you’ve installed it etc., etc.

i used this guide to set up but i used linux mint 19.3 as a base OS

got a free DNS from no-ip and used letsencrypt as it says in the guide.
forwarded the ports 80 and 443 on the modem/router(the one provided by the isp) for the static LAN IP for the computer.

Then i just changed default target in sysctl so that computer goes straight to CLI instead of GUI because its a dual-core with only 4gb ram.