Can´t use collabora online because certain connections are using http instead of https even all settings are set to https

Hi,
I am running nextcloud as docker image on port 80 and use a reverse proxy for ssl. The collabora online server also uses https but however if I try to open an office document it´s loading but no document appears. If I check the browser console I am getting the following information:

Content Security Policy: Die Einstellungen der Seite haben das Laden einer Ressource auf http://collaboraonlinedomain.com:9980/loleaflet/173510f/loleaflet.html?WOPISrc=https%3A%2F%2Fintern.parkclub-igls.com%2Fapps%2Frichdocuments%2Fwopi%2Ffiles%2F9407_ocni3mjzb23o&title=2019%20Ballausgabe.xlsx&lang=de-AT&closebutton=1&revisionhistory=1 blockiert (“frame-src”).

How is it possbile that the application tries to make an http connection even, the URL to the collabora online server is https://collaboraonlinedomain.com:9980?

Therefore it´s clear that collabora is not working in nextcloud.

Thanks,
Florian

1 Like

Hello,

I dont have the answer to your question, however you should check to see if in your nextcloud admin > settings > collabora online > Collabora online server is http or https.

From my own experience I think that it will be “http”, and your browser is blocking mixed content, http through https. And when you change the “Collabora online server” value to “https”, I think you will have a “Saved with error”.

Edit: I think that the right direction is to change it to https, but then I am also stuck with the “Saved with error”
problem.

These are just my assumptions from what I have experienced.

Thank you for the response,
I have set the Collabora online server URL to https, but however it seems when opening a file some code still tries to connect via http, but this can´t work, because the reverse proxy is blocking this and as already mentioned by you, I would get the error because mixed content is blocked.

Florian

I could solve the problem in the following way:

  1. Installed the docker immage of collabora-online with the following configuration:
    domain: intern\.mydomain1\.com|intern\.mydomain2\.net
    LC_CTYPE: en_US.UTF-8

Therefore collabora-online was configured using ssl.
2. Checked the functionality in the server with curl: curl -k https://127.0.0.1:9980
3. Configured my reverse proxy the following way:

  • Installed the right certifcate on the reverse proxy
  • Created the following rule for the reverse proxy:
    SSL overload: enabled
    Reencrypt: enabled
    Performed the following Port tranlation: The revers proxy is listening on port 9981 and translate it to 9980 and sends the request to the collabora-online docker instance.

With this “clue” the collabora-online sever ist now working with nextcloud.

Florian

1 Like

I’m having the same issue. Collabora returns a blank page, and in console.logs, it shows the message:

Mixed Content: The page at 'https://collabora.domain1.com/apps/files/?dir=/Executives/Finance&fileid=868' was loaded over HTTPS, but requested an insecure form action 'http://collabora.domain1.com/loleaflet/0b3211b/loleaflet.html?WOPISrc=https%3A%2F%2Fcollabora.domain1.com%%2Findex.php%2Fapps%2Frichdocuments%2Fwopi%2Ffiles%2F1729_ocixug9hl9fs&title=investments.ods&lang=en&closebutton=1&revisionhistory=1'. This request has been blocked; the content must be served over HTTPS.

@nta can you share what your nginx.conf looks like and highlight the changes you made to make it work?

Also having a similar issue.
Running the following results in a blank page:
docker run -t -d -p 192.168.0.whatever:9980:9980 --name collabora_code --restart always -e "extra_params=--o:ssl.enable=false" collabora/code

Presuming it had something to do with ssl, running the following (and changing the corresponding ip to use https in admin settings) resulted in a “Ooops, click try again to reload” from Firefox:
docker run -t -d -p 192.168.0.whatever:9980:9980 --name collabora_code --restart always -e "extra_params=--o:ssl.enable=true" collabora/code

In both cases, nextcloud determines the server as “reachable”.

EDIT: Whoops, didn’t realize this was an old thread with the reply above me. Nta’s explanation is a bit confusing for a shall we say “new” admin to this kinda thing :slight_smile:

This solved the issue!