Can not browse "not enabled" apps. Allowed memory size exhausted

I’ve recently installed NextCloud 9.0.52 and enabled the “external storage” app.
However, since then, I can’t go back to the list of “not enabled” apps. Every time I do so, I get an error message “Problem loading page, reloading in 5 seconds”.
The “owncloud.log” file gives an error message each time I try this:
{“reqId”:“V48zTpZ-jUWu17-FWytZ6wAAAAg”,“remoteAddr”:"",“app”:“PHP”,“message”:“Allowed memory size of 1073741824 bytes exhausted (tried to allocate 140464379990016 bytes) at /nextcloud/lib/public/appframework/http/jsonresponse.php#68”,“level”:3,“time”:“2016-07-20T08:16:15+00:00”,“method”:“GET”,“url”:"/nextcloud/index.php/settings/apps/categories",“user”:“admin”}
If I have to believe this message, the system tried to allocate 127 TB worth of memory … which logically won’t ever succeed.
I’ve upgraded NextCloud to 9.0.53 this morning, but unfortunately, this hasn’t resolved the error.
As seen in the above message, I’ve already upped the php memory_limit value to 1024MB … any more isn’t really an option.

What can be the cause of this error ?

Theres a default php memory limit of 128MB in your php.ini, change that

As I’ve said (and as can be seen in the actual error message), the php memory_limit is set to 1024 MB already.

Also, I clearly can’t change the php memory limit to 127 TB … which is what it apparently tries to allocate.

It’s probably better to report this on github using the template with all information about your setup.

You can try to disable the external storage trought occ command

…and try again.

If it still fails…what is your distribution? php version?


I just stumbled upon this too, after upgrading PHP 5.6 to PHP 7.0. No idea yet how to fix it.

The problem in my case was APCu cache.

Nextcloud app page started working again after I disabled
'memcache.local' => '\\OC\\Memcache\\APCu',
in config.php.

I compared (CentOS7) apcu.ini versions between
and there weren’t any differences to them.

In the end I just stopped using APCu with Nextcloud and all is fine.

For the future reference, APCu package in CentOS7 was:
from the Webtatic’s repository.

Ubuntu 14.04 LTS didn’t have any problems (at least) with
php-apcu amd64
that comes from the Ondrej’s repo.