Can I share a full resolution image that is viewed online?

The image I share is not available to be viewed in full resolution online via Nextcloud.

Steps to replicate it: View this image. Then download it. What you view online is not the same as what you download. It should be.

Nextcloud version (eg, 20.0.5): 21.0.1
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04
Apache or nginx version (eg, Apache 2.4.25): don't know, it's running on Cloudron
PHP version (eg, 7.4): 7.4.3

See here for reference, Image preview in sharing page should show the full image · Issue #7614 · nextcloud/server · GitHub .

very well done to search for an existing github issue!

and you filed yourself a new one… good as well. →

(maybe you want to add “regression”-tag to it?)

so this would mark your thread here as being solved - by definition, I’m afraid.

regession? I don’t think it was available in a previous Nextcloud version, but if it was I am sure all the improvements since then outweigh this feature. Not sure what you mean.

Nextcloud still functions this way as far as I know. How is it solved? Can I provide a link to someone where they can view an image full size?

referring to this GH-issue it was working at some point (or it wouldn’t have been closed)

And from what I know it could happen that a new feature or new code could indeed break some older stuff… and in this case devs are adding a regression-tag.

but hey… i was only suggesting it. you don’t really need to add that tag. no worries

I am not sure but I do not think you are right about “working at some point”. I did not know what the regression tag was for, but I will keep that in mind for future bugs for which it is appropriate. I am not able to add the regression tag on the Github issue.

Edit: I am better understanding your first reply, now that I realize this is the help forum and not Github.
Perhaps there is a good work-around? Or perhaps I am mistaken somehow? Or I need to upgrade something? Or …? But I’ll take your first reply as solving the issue in this forum.

Edit 2: I asked this question incorrectly, and it received a simple answer of “no”, so I have asked the correct one here, What is the best way to share full resolution images online?.

1 Like

I learned about an excellent work-around (for me) from another user on this forum: search for Sharing Path on your Nextcloud Apps page. From there install it on your Nextcloud.

Read more about the app on its Github page. I found even the security to be good: it allows access only if a “Sharing link” was created from the more standard Nextcloud sharing feature.

1 Like

Hi. I was the “another other”. I posted it with PM because i thought it is the wrong way. :wink:

Bu now I found another solution. But it only works with single shared images.

Link e.g: https://cloud.server.tld/s/L6bybM5ZzKGdSfS
Full size: https://cloud.server.tld/s/L6bybM5ZzKGdSfS/preview

I have test it with Nextcloud 21.
Now you have perhaps two solutions.
But i think in websites you can better use Sharing Path.

Read also Sharing direct link to image with specific size · Issue #16239 · nextcloud/server · GitHub

Have you tried this for the image I linked to in my original post? It does not work.

Neither does setting:
preview_max_x' => 20000,
preview_max_y' => 20000,
, for example, in the config.php file, as the first post in your Github link metions. And the post you linked to, which mentions fiddling with the “copy image URL”, which is not worth it anyway, also does not work.

So Sharing Path it is!


Have you test the url extension in my last post? Does ist work? What happens?

Link e.g: https://cloud.server.tld/s/L6bybM5ZzKGdSfS
Full size: https://cloud.server.tld/s/L6bybM5ZzKGdSfS/preview
(no parameter after “preview”)

What do you not understand about my question? By original post, I mean my first post in this thread.

Ok. What is your share?

Have you test “/preview” without another parameter to access full resolution image?

[Required filler.]

this link for full resolution image:

Is this correct? Compare with origin.


No. [More filler.]

You could use /download instead of /preview to receive the original file. But that won’t display the file in the browser.

@Chartman123, did @devnull recruit you to join him in filling up this thread with useless replies? ; )

No, just pointing out your possibilities. Glad I could NOT help you. I will never bother you again :wink:

I began this discussion by pointing out that possibility:

Yes it was my fault. The preview is in your case not the origin.
On one of my server it was the origin size. Sorry.

I think i do not understand the managing of image from nextcloud.
Perhaps someone can explain it.