Calendar not compatible with NC 21

This app cannot be installed because the following dependencies are not fulfilled:
Server version 19 or lower is required.

will there be an update to the calendar?

Hi @peterd550, yes there is a version for nextcloud 21: Releases - Calendar - Apps - App Store - Nextcloud