Calendar app broken since update to nextcloud 10.0.2

Since updating nextcloud to version 10.0.2 and re-enabling all apps, the calendar app view does not work. Instead, the following is shown:

The account used for testing contains three calendars. The CalDAV backend and connected clients are still working as expected.

What could be the cause of this issue? How can it be fixed? Many thanks!

Hey, this is probably not related to the update to 10.0.2, but by updating the calendar to 1.4.1.
Any chance you disabled the Sharing API in the admin settings?

That would be possible. The calendar version currently in use is 1.4.1. And I did indeed disable the Sharing API for apps. I tried to temporarily enable the Sharing API, but the issue still persists. Is there something else I could try?

I have exactly the same problem.
But also a downgrade of the calendar app wasn’t possible. It was saying that I’m not able to activate the "older "calendar upp. I needed to update to 1.4.1 again.

I had the same problem. I had to enable the allow “Allow apps to use the Share API” in then Admin panel and install the “File sharing” - App in the Apps panel. After doing both the calender app worked.


Thank you so much, bart! That worked for me too.

It’s a bit unfortunate you have to enable the sharing API just to use calendars, even if you don’t intend to share them.