Caldav/carddav warning, but .htaccess had correct settings

Nextcloud version: 14.0.4
Operating system: Linux 3.10.0-962.3.2.lve1.5.24.4.el7.x86_64 #1 SMP Thu Nov 15 03:49:47 EST 2018 x86_64 x86_64 x86_64 GNU/Linux
Apache (do not know version my provider is using)
PHP 7.1

I got warnings at admin panel

Your web server is not set up correctly to resolve "/.well-known/caldav".
Your web server is not set up correctly to resolve "/.well-known/carddav".

but my .htaccess is filled like described in Nextcloud-documentation.
https://docs.nextcloud.com/server/14/admin_manual/installation/source_installation.html#apache-web-server-configuration

RewriteRule ^.well-known/host-meta /nextcloud/public.php?service=host-meta [QSA,L]
RewriteRule ^.well-known/host-meta.json /nextcloud/public.php?service=host-meta-json [QSA,L]
RewriteRule ^.well-known/webfinger /nextcloud/public.php?service=webfinger [QSA,L]
RewriteRule ^.well-known/carddav /nextcloud/remote.php/dav/ [R=301,L]
RewriteRule ^.well-known/caldav /nextcloud/remote.php/dav/ [R=301,L]

this file is really used, another modification of mine (Strict-Transport-Security) was recognized immediatly.

I had problems with DAV5x after this migration. Android App can not sync anymore :frowning:

any help, hints and tips are welcome

snowy

Try to put these lines in /etc/apache2/sites-enabled/nextcloud.conf and restart apache. Replace [your_domain] with real domain.
Redirect 301 /.well-known/carddav [your_domain]/nextcloud/remote.php/dav
Redirect 301 /.well-known/caldav [your_domain]/nextcloud/remote.php/dav
I have same problem and after these change the warning disappeared.

Thank you very much for the recommendation.
Unfortunately the provider does not give me access to Apache settings

I put [myDomain] in .htaccess like your example, but this does not help
After that I tried to put your lines at the end of .htaccess (copied from your hint, with correct domain), but in this case nextcloud could not be reached anymore.

I try’it myself solution to change .htaccess but not working.
It seems to be a common problem, and most have resolved by adding the two lines in the nextcloud.conf file.
Unfortunately, if you do not have access to the apache server, I do not know what you can do.

I upgrade to 15.0.2 now, but problem still the same
no other solution without changing apache-settings?

Auto-Discovery of DAV-Clients seems not to work anymore :-1: