CalDAV, CardDAV, Nodeinfo, and Webfinger errors in NC21

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

I’ve just upgraded to NC 21 and I’m getting error messages saying " Your web server is not properly set up to resolve “/.well-known/webfinger”. Further information can be found in the documentation." I’m also getting the same message for CalDAV, CardDAV, and Nodeinfo. I’ve searched the archives and Google for help, but haven’t been able to resolve the issue. Can anyone shed any light on the subject? is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version 21.0.0
Operating system and version Ubuntu 20.04
nginx version 1.19.7
PHP version 8.0.3

The issue you are facing:

Is this the first time you’ve seen this error? Y

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:

Debug	files_sharing	/appinfo/app.php is deprecated, use \OCP\AppFramework\Bootstrap\IBootstrap on the application class instead.	

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'ocaro7r930mk',
  'passwordsalt' => 'BHVfJfqlcPFLlgq0MrT1SNxvT74j16',
  'secret' => 'q+U6EmpeYxsp4k1Aluova+y/NlTFr1itL622WmA+UK1VP2ma',
  'trusted_domains' => 
  array (
    0 => '',
  'datadirectory' => '/usr/share/nginx/nextcloud-data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'redacted',
  'dbpassword' => 'redacted',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'tls',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'wizard',
  'mail_domain' => '',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtphost' => '',
  'mail_smtpport' => '587',
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.local' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'redis' => 
  array (
    'host' => 'localhost',
    'port' => 6379,
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 0,
  '' => 'stable',
  'updater.secret' => '$2y$10$UThEKRzSpGr1GzkYOuiXbea9iJS5TkJMjuNxLafgVBmXC2sV1dow2',

The output of your nginx system log in /var/log/____:

Not available

Afaik, these kind of problems has already been reported so please use the search function of the forum to find related postings.

That’s all well and good, j-ed, but I’ve been searching the forum for days without finding a working solution. I’ve tried

location = /.well-known/carddav {
    return 301 $scheme://$host:server_port/remote.php/dav;


location = /.well-known/carddav {
    return 301 /nextcloud/remote.php/dav;

and neither of them resolves the issue. CardDAV worked well in NC20 and I can’t figure why it has stopped.