Caching has potentially stopped working since 9.0.52 > 10.0.0.0 upgrade

Indeed I know, usually running that shows everything in the directory but in this case it just tells me there are 500 records :slight_smile:

I figured APCu cache would be lumped in with the upload cache, so thanks for clarifying that!

No idea, perhaps some performance issue? You could select a more specific pattern to reduce the number of files: e.g. ls -la .a*. If this is new in Ubuntu 16.04, it should be documented somewhere, or search with the exact output for more information.

Just to be certain & for clarity, the newly edited apcu.ini file has:

extension=apcu.so
apc.enabled=1
apc.enable_cli=1
apc.shm_size=128M
apc.ttl=3600
apc.user_ttl=7200
apc.gc_ttl=3600

Thanks for finding this!

1 Like

Funny thing, now that I enabled debug log again, i realized the same info messages with the cron jobs every 15 minutes. But actually my phpinfo() shows β€œAPCu Support Enabled” and also the main admin panel page does not show the expected error about missing memory cache.

I remember that I already had this in the past with owncloud, but as I am not wrong I handled the change of the apcu.ini as obsolete as apc.enabled=1 is set as default or something. But maybe the apc.enable_cli=1 is not and therefore the context app of the message is also β€œcli”?

EDIT: http://php.net/manual/en/apcu.configuration.php There it is: defaults are β€œapc.enabled=1” but β€œapc.enable_cli=0”.

This is what they say about the cli setting:

Mostly for testing and debugging. Setting this enables APC for the CLI version of PHP. Under normal circumstances, it is not ideal to create, populate and destroy the APC cache on every CLI request, but for various test scenarios it is useful to be able to enable APC for the CLI version of PHP easily.

This explains why it is not handles as error in nextcloud, just as info while running the cron jobs. Maybe someone can say something about the actual effect of this setting on nextcloud? But after all it seems to be okay for me to leave it disabled, as far as apc.enabled=1 of course (as is as default) and also phpinfo() shows proper APCu support.