Cache Warning went away but logs complain about OPcache

Hi,

I use NextCloud 13.0.4.0 on Centos 7.x with php 7.1 and apache

Warning about memcache not configured went away on NC Web Interface however I still receive error on nextcloud.log:

“reqId”:“WyPdi6gKvvtyFx5-KdaIJAAAAAQ”,“level”:3,“time”:“2018-06-15T15:39:05+00:00”,“remoteAddr”:“192.168.0.3”,“user”:“admin”,“app”:“PHP”,“method”:“GET”,“url”:"/nextcloud/settings/ajax/checksetup",“message”:“Zend OPcache can’t be temporary enabled (it may be only disabled till the end of request) at Unknown#0”,“userAgent”:“Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0”,“version”:“13.0.4.0”

I’ve tried every location and post I’ve found here and the error persists, please could you help me?

This my php config:

# php --ini | grep -E  'opcache|apcu'
Additional .ini files parsed => /etc/opt/rh/rh-php71/php.d/10-opcache.ini,
/etc/opt/rh/rh-php71/php.d/40-apcu.ini
apcu
opcache.blacklist_filename => /etc/opt/rh/rh-php71/php.d/opcache*.blacklist => /etc/opt/rh/rh-php71/php.d/opcache*.blacklist
# php -i | -E  'opcache|apcu'
opcache.consistency_checks => 0 => 0
opcache.dups_fix => Off => Off
opcache.enable => On => On
opcache.enable_cli => On => On
opcache.enable_file_override => Off => Off
opcache.error_log => no value => no value
opcache.fast_shutdown => 0 => 0
opcache.file_cache => no value => no value
opcache.file_cache_consistency_checks => 1 => 1
opcache.file_cache_only => 0 => 0
opcache.file_update_protection => 2 => 2
opcache.force_restart_timeout => 180 => 180
opcache.huge_code_pages => Off => Off
opcache.inherited_hack => On => On
opcache.interned_strings_buffer => 8 => 8
opcache.lockfile_path => /tmp => /tmp
opcache.log_verbosity_level => 1 => 1
opcache.max_accelerated_files => 10000 => 10000
opcache.max_file_size => 0 => 0
opcache.max_wasted_percentage => 5 => 5
opcache.memory_consumption => 128 => 128
opcache.opt_debug_level => 0 => 0
opcache.optimization_level => 0x7FFFBFFF => 0x7FFFBFFF
opcache.preferred_memory_model => no value => no value
opcache.protect_memory => 0 => 0
opcache.restrict_api => no value => no value
opcache.revalidate_freq => 1 => 1
opcache.revalidate_path => Off => Off
opcache.save_comments => 1 => 1
opcache.use_cwd => On => On
opcache.validate_permission => Off => Off
opcache.validate_root => Off => Off
opcache.validate_timestamps => On => On

If you need that I submit more information, please let me to know.

Thanks in advance

Well, well, finally I’ve found the solution. I’ve configure opcache parameters both on .user.ini and php.ini files, so I think that it complained that it could not enable opcache twice.

So, I commented out opcache directives on .user.ini and voilá! log warnings finally went away too!

Hope that helps everyone

Greets!