Bulk Import Photos and Videos from USB drive into NextCloudPi

I have NextCloudPi on Raspberry Pi 2 with External USB drive, and trying to Bulk Import Photos and Videos from USB drive into NextCloudPi.

Tried the nc-scan command from root login on the USB folder (/media/myhdd) however it did not scan anything.

Is there an option to bulk import all my photo/video into NextCloudPi

Please help!

More details please.

Ran the nc-scan from web gui

Also, the path for the photos

root@NextCloudPi:/media/USBdrive# find . -type f | wc -l

Additionally, www-data has ownership of the photos folder

root@NextCloudPi:/media/USBdrive/Photos# ls -l
total 36
drwxr-xr-x 3 www-data www-data 4096 Jan 8 16:37 2010
drwxr-xr-x 3 www-data www-data 4096 Jan 16 17:39 2013
drwxr-xr-x 4 www-data www-data 4096 Jan 8 19:41 2016
drwxr-xr-x 4 www-data www-data 4096 Jan 8 19:41 2017
drwxr-xr-x 3 www-data www-data 4096 Dec 29 23:18 2018
drwxr-xr-x 10 www-data www-data 4096 Jan 26 02:15 2019
drwxr-xr-x 9 www-data www-data 4096 Jan 7 02:57 2020
drwxr-xr-x 3 www-data www-data 4096 Jan 1 20:00 2021
-rw-r–r-- 1 www-data www-data 150 Dec 29 23:12 Readme.md

Did you run nc-fix-permissions before nc-scan?

I think the folder Photos must be inside a user’s folder.

Yes, I did run the nc-fix-permissions before the nc-scan.

I am looking for Bulk import of media into a User on NextcloudPi.

Do you mean, I need to manually “move” the Photos folder / content inside the Photos folder for a user already on NextCloudPi?

Yes and then run nc-fix-permissions and nc-scan

You can find that options on the NextCloudPi web panel under tools

Did that, moved sample set of 400 photos into the Nextcloud user’s Photo folder

ran the nc-fix-permissions (result came as done) and then nc-scan

[ nc-scan ] (Fri Jan 29 20:58:16 GMT 2021)
Unknown user 1 media

| Folders | Files | Elapsed time |
| 0 | 0 | 00:00:00 |

Photos are still not being shown or imported.

What is your NextCloudPi version?
The last NextCloudPi version is V 1.34.7

This is the current version NextCloudPi 20.0.4 and upgrading to 20.0.6 (in progress now)


Ran the upgrade, and the install log had this:

NextCloudPi updated to version v1.30.0
Running unattended-upgrades
Unattended upgrades active: yes (autoreboot true)
NextCloudPi updated to version v1.34.7
Done. Press any key...

So version shows as v1.34.7

Running the fix permission and scan again now

same response:

I run in to that problem some time ago and that was a bug that was solved.
That’s the reason I asked for the version.
Try to run nc-scan with the path’s empty.
RPI2 is to slow for Nextcloud, I think is better to use the terminal version of web-panel.
Login by SSH and run “sudo ncp-config”, then go to tools and run nc-scan

yep, done this via ssh command-line as well,

same results,

root@NextCloudPi:~# ncp-config
Running nc-fix-permissions
fixing permissions in /media/root/ncdata… done
Done. Press any key…
NextCloudPi installer configuration

  Enter configuration for nc-scan

   RECURSIVE     yes
   PATH1         /media/USBdrive2/ncdata/<user>/files/Photos/Photos

                    <Start >          <Cancel>

Running nc-scan
Unknown user 1 media

| Folders | Files | Elapsed time |
| 0 | 0 | 00:00:00 |
Done. Press any key…


Did you tried with all the 3 path’s empty?

Do not update to 20.0.6. There are issues and thats why NextCloudPI is on 20.0.4

tried all the 3 paths, same result for both TUI and Web GUI, media photos are still not imported.

Also, looks like the nc-udpate only updated the NextCloudPi version to 1.34.7 and NextCloud is still on 20.0.4.

Yes, NCP will be on 20.0.4 until all NC issues are solved

Please paste “ncp-report”
Use pastebin

ncp-report on pastebin

Any help anyone, how to bulk import photos and videos into NCP?