Builderror NextcloudPI for XU4

Hello,

i use:

git clone https://github.com/nextcloud/nextcloudpi.git
cd nextcloudpi
./build-SD-armbian.sh odroidxu4

and this are the errors:

[ o.k. ] Installing packages for [ Armbian ]
Reading package lists…
Building dependency tree…
Reading state information…
E: Unable to locate package armbian-firmware
[ error ] ERROR in function create_rootfs_cache [ debootstrap-ng.sh:216 ]
[ error ] Installation of Armbian packages failed
[ o.k. ] Process terminated
[ error ] ERROR in function unmount_on_exit [ image-helpers.sh:60 ]
[ error ] debootstrap-ng was interrupted
[ o.k. ] Process terminated

someone can help me?

greetings

You can download the image for the XU4 at nextcloudpi.com (it is the same one as the HC2)

Hello, I tried to install NextcloudPI to a XU4 with emmc, but never boots :frowning: from emmc

When I use ddsd I only have one partition:
sdb 8:16 1 29,1G 0 disk
└─sdb1 8:17 1 1,9G 0 part

and it never boots…
when I try it with ddsd and image from diatpi I have two partitions and it boots.
EDIT: on retropi the emmc works also…

is this a problem with the image NextCloudPi_OdroidHC2_09-29-18.img?

nachoparker, no idea?

I have never tried to run it from eMMC. You might need to get help in the Armbian forums.

I know that it works from the SD card

yes it works from SD card… :wink:

I thought it was a build think…