Bugs after Update to JSON Monitoring

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version:
Operating system and version: Debian 10 5.10.52-v8+
Nginx version: 1.21.1
PHP version: 8.0.9

The issue:
Monitoring link in JSON format brings letter “d” at the end causing problems with monitoring software.


Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

Monitoring link as shown in nc webGUI


Uhm well, so no one? I attached the JSON. Request is just fine and what ever which way I get it there is this „d“, started after update.

What’s the SLA of none enterprise users, probably none.

So maybe I will wait till next update patch, hopefully that will fix it and my monitoring which I was building up over many days of my lifetime will work again properly. :slight_smile:

I made update to 22.1.1 RC1 and can you imagine…did not change anything. Still no monitoring, still many issues with NC22.

This is the API of the serverinfo app?

I didn’t see a related bug report: Issues · nextcloud/serverinfo · GitHub

Your code integrity check doesn’t show a problem?

Thank you for taking care about this. Yes I am doing a curl command on localhost to get the JSON from NC. Everything worked fine till I upgrade to and I didn’t change anything. The weird thing is there is no „d“ at the end while I am doing it on browser.
I created a zabbix template for it and also shared it:


There is no feedback about any issues but this doesn’t mean anything. Template took me like 2 days and I was so happy for 2 weeks about propper working.


I am getting JSON with following command:


Fixed it. Had a mistake in the curl command. Monitoring can go on. :slight_smile: