[Bug] Upgrade to 11.0.0

I upgraded to NextCloud 11.0.0 and the Contacts that I had listed in the system are no longer appearing. Do I need to adjust something to make them appear?

There should not be any step necessary. Of course you always need to enable and update the contacts app after nc upgrade.

Other parts of the database were migrated successfully, i.e. all calendar entries are still there?

I didn’t have any Calendar entries so I cannot tell on that part. I did enable the app i just get a spinning wheel when I go to the contacts app.

At the moment I am just using it for the contacts to sync to Cell Phones.

I have 2 NextCloud servers and I upgraded both from 10.0 and they both have the same issue.

I do get this:
Failed to load resource: the server responded with a status of 500 (Internal Server Error)

Uncaught (in promise) Error: Bad status: 500
at XMLHttpRequest.request.onreadystatechange

Uncaught (in promise) Error: Bad status: 500
at XMLHttpRequest.request.onreadystatechange

It appears it cannot load the address books of the user. I just don’t know where to start to fix it.

I also see this error in the logs:

Sabre\DAV\Exception\UnsupportedMediaType: HTTP/1.1 415 This resource only supports valid vCard or jCard data. Parse error: Unsupported CHARSET: utf-8

  1. /var/www/nextcloud/3rdparty/sabre/dav/lib/CardDAV/Plugin.php - line 316: Sabre\CardDAV\Plugin->validateVCard(‘BEGIN VCARD\r\nVE…’, false)
  2. [internal function] Sabre\CardDAV\Plugin->beforeCreateFile(‘addressbooks/us…’, ‘BEGIN VCARD\r\nVE…’, Object(OCA\DAV\CardDAV\AddressBook), false)
  3. /var/www/nextcloud/3rdparty/sabre/event/lib/EventEmitterTrait.php - line 105: call_user_func_array(Array, Array)
  4. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 1070: Sabre\Event\EventEmitter->emit(‘beforeCreateFil…’, Array)
  5. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php - line 525: Sabre\DAV\Server->createFile(‘addressbooks/us…’, ‘BEGIN VCARD\r\nVE…’, NULL)
  6. [internal function] Sabre\DAV\CorePlugin->httpPut(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
  7. /var/www/nextcloud/3rdparty/sabre/event/lib/EventEmitterTrait.php - line 105: call_user_func_array(Array, Array)
  8. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 479: Sabre\Event\EventEmitter->emit(‘method PUT’, Array)
  9. /var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 254: Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
  10. /var/www/nextcloud/apps/dav/lib/Server.php - line 227: Sabre\DAV\Server->exec()
  11. /var/www/nextcloud/apps/dav/appinfo/v2/remote.php - line 30: OCA\DAV\Server->exec()
  12. /var/www/nextcloud/remote.php - line 165: require_once(’/var/www/nextcl…’)
  13. {main}

Along with this:

Sabre\DAV\Exception\NotAuthenticated: HTTP/1.1 401 No ‘Authorization: Basic’ header found. Either the client didn’t send one, or the server is misconfigured, No public access to this resource., No ‘Authorization: Basic’ header found. Either the client didn’t send one, or the server is misconfigured, No ‘Authorization: Basic’ header found. Either the client didn’t send one, or the server is misconfigured
[internal function] Sabre\DAV\Auth\Plugin->beforeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
/var/www/nextcloud/3rdparty/sabre/event/lib/EventEmitterTrait.php - line 105: call_user_func_array(Array, Array)
/var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 466: Sabre\Event\EventEmitter->emit(‘beforeMethod’, Array)
/var/www/nextcloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 254: Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
/var/www/nextcloud/apps/dav/lib/Server.php - line 227: Sabre\DAV\Server->exec()
/var/www/nextcloud/apps/dav/appinfo/v2/remote.php - line 30: OCA\DAV\Server->exec()
/var/www/nextcloud/remote.php - line 165: require_once(’/var/www/nextcl…’)
{main}

And that did work before the upgrade? If such a thing just happens after an upgrade, please report it directly to https://github.com/nextcloud/server/issues

It did. I ended up building it from scratch.

Hello mb5200,

I’ve got the same issue with Sabre and HTTP/1.1 415 exception for the Contact app after upgrade from NextCloud 10 to NextCloud11.
What do you mean by building it from scratch?
I fear that you mean really “from scratch”, so a really new NextCloud 11 install instead of an upgrade: no existing DB and data from previous version.

I analyzed different users status for their Contacts: users without contact before migration have no issue: they can add new ones without trouble. User with contacts before migration cannot access them and cannot create new ones, the refresh is always pending.
It seems that the migration process for contacts in the DB is not 100% efficient yet.

I think it has to do with the contacts and how they were imported. I was able to export it from the old system and import it into the new system. I didn’t retry the upgrade and import them but it basically corrupts the address book(s) so if you can remove them and add them back it works but it’s an upgrade issue.

I ended up starting with a new VM and built a whole new setup and got it to import the contacts I exported from the old system and then was able to get it functioning with no issues but it was a long process

If you still have the old image with the problem, it would be helpful to report such issue on the butracker in order to get such problems solved. It prevents running into the same error on each update.

I solved it on my side also with similar solution: delete manually all the addressbook entries in the SQL DB of the concerned user (user was again able to create from Contacts App new contact). Then, as the user created his contacts through a CardDAV application on his smartphone he did again the synchronisation with his nextcloud account.
After that all his contacts are again available in Contacts App under Nextcloud.
I do not know if it is a generic migration issue for contacts or if it is only when contacts are imported through a cardDAV link them migrated.

I do have the image still.

What are you using to backup the data on your instances? Looking for a rock solid backup that doesn’t require a ton of maintenance

For backup, on my side, basically rsync and mysqldump (whole web data directory on other HDDs: 1 for every nigth and 1 for every week backups and the same for the needed DBs) and CRON for scheduling. Basic but efficient until now.

When upgrading to OC 11, the settingst for sync clients for Android and iOS have changed. Please have a loof at the web application for the current settings.

Hi,

i have a fresh install on banana-pi.
Nextcloud 11.0.1 (stable)
When i try to import contacts from thunderbird or google,
i get:

Fatal webdav Sabre\DAV\Exception\UnsupportedMediaType: HTTP/1.1 415 Validation error in vCard: CardDAV servers are not allowed to accept vCard 2.1. 2017-01-18T22:53:39+0100

@icho40 your vcard version are obsolete. Please upgrade them. This has been discussed on github already.

Since your issue isn’t related to the initial one. I’m closing this.