[Bug] Contacts 2.x.x GUI broken with apps folder outside web installation

nc12

#1

Hello there,
since I upgraded my contacts to 2.0.0 (or later) my contacts GUI is kind of broken, see this screenshot here https://screenshots.firefox.com/wPuouB1Fnbsu3dvA/nextcloud.familie-kreimeyer.de.

Does not work on either Chromium or Firefox, tried deleting and reloading the app. Contacts work fine though, so I guess its an issue in my Nextcloud or the contacts app.


#2

Do you have any css/js optimization of cloudflare or a similar serivce activated?
Anything in your browser’s console/network log (especially is the *.css file successfully loaded)?
Anything in the nextcloud log?
Does the same problem occur if you use the private browsing mode of your browser?
(Alternatively would you mind trying to clear your browser’s cache?)

Edit: Sorry for not replying in IRC - most of us are idling a lot of the time :wink: and mostly by the time someone could answer, the person asking the question has already vanished from the server.


#3

I have cleared cache and even tried a different browser, the server is hosted on my own vserver using wonderfalls nextcloud docker image. I noticed the theming addon made a few other buttons not work, after disabling most buttons work fine again. Contacts still is broken. Also this in my Browser console in Firefox:

Content Security Policy: The page's settings blocked the loading of a resource at self ("script-src 'nonce-akN6Z0NMRmtrRTRZOVhHQU1KYUttUEN0cDBaclB2M2E2anBpYWRYNU5KVT06M2h5WGZQUXB1d04ydmpiMmR2amQ5YkhQOGc0TWVvV1hxMUVGTUtPdlJkcz0=' 'unsafe-eval'"). Source: ondrop attribute on INPUT element.

Also my bouncer is not online right now, so I used the webchat. Will get my bouncer running in the next week then IRC won’t be a problem.


#4

And in the network tab of your browser’s console? Do all requests get handled successfully? Do you find one request for a css file in there?


#5

JQMIGRATE: Migrate is installed, version 1.4.0 core.js:7:542
Use of getAttributeNode() is deprecated. Use getAttribute() instead. core.js:7:1714
Use of attributes’ nodeValue attribute is deprecated. Use value instead. core.js:7:1714
Content Security Policy: The page’s settings blocked the loading of a resource at self (“script-src ‘nonce-MTdiMGFiSnYwTU5yU21tcHZGT1ZSZlBCM01RU1BLUmZCTEoyc2NSNEFsMD06aFlhREhmY2krNDRGQVM3ZitqM0NLTEtqaVl4MWVOd1NSZGtSNkxJdWN4TT0=’ ‘unsafe-eval’”). Source: ondrop attribute on INPUT element.

also this is in my nextcloud.log:

{“reqId”:“JwVO0G1A3jsf2JwrCvMo”,“level”:3,“time”:“2017-10-21 23:31:23”,“remoteAddr”:“172.17.0.5”,“user”:“nico”,“app”:“lib”,“method”:“GET”,“url”:"/apps/contacts/",“message”:“ResourceLocator can not find a web root (root: /apps2/contacts, file: css/contacts/12121caab732a6e209f61f58d35de7e0-style.css, webRoot: , throw: true)”,“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0”,“version”:“12.0.3.3”}


#6

Any updates on this?

Found the issue, was related to my apps2 folder not being inside of the webroot of the server.


#7

Sounds like it was caused due to the contacts app beeing in a different folder outside root in your case.
Should be fixed by https://github.com/nextcloud/server/pull/7257.


#8

@Keridosis it fixed?


#9

Closing as the fixed has been shipped with latest stable13 releases.
Please upgrade asap if you encounter the same issue :slight_smile:


#10