[Bug] Contact app broken on new 17.0.1 installation

I’ve tried to install NC and the Contacts app several times but I always arrive at the same result:

  1. Uploaded 17.0.1 zip file to an empty subdomain on a shared hosting account
  2. Ran install, connected to a new database I set up via cPanel Databases
  3. Logged in, went to Apps and installed Contacts
  4. No menu icon shows but the “Contacts” text shows when hovering over the menu item
  5. Clicking the Contacts menu item yields a page with the menu and nothing else.
  6. My nextcloud.log file is empty
  7. PHP version 7.1

I ran an older version of NC early this year (2019) with Contacts and Calendar which ran perfectly until it somehow got corrupted. I’ve since wiped the original and tried to install a new NC (from both the .zip file and the Web Installer) but it has turned out the same.

I’m assuming it’s something on the hosting service that’s not set correctly but I have no idea what it is.


I cant get contacts to work either. Any update?

Same behaviour in 2 NC installation/ upgrade on different platforms. Blank page, and it seems all permissions are fine. Any clue?

UPDATE: works after update my old browser!

Is the contact app working for anyone on 17.x now? Just asking because I like to get an idea how common this is. I could help in understanding why this happens.
I am holding of the upgrade for now.

update: contacts works for me after upgrading…

1 Like

Are any NC developers even seeing this thread?

Yep :slight_smile:

Please update your nextcloud contacts app.
There was an issue with an old release, I cannot reproduce the issue anymore (17 & 18)