Broken photo page after scanning files from Syncthing

I’ve been using Nextcloud AIO along with Syncthing (I have a dependency on it) but when adding a new file and running chown -R 33:0 and chmod -R 750 and php occ files:scan --all (following), the photos page does not load the photos.

I did several tests, I tried to synchronize in different ways, with different permissions, I tried with convmv (convmv -f utf-8 -t utf-8 -r --notest --nfc), but nothing. Everything goes back to normal if I remove the file synced by Syncthing. That for any file, from a .md to a .png, anything I sync via Syncthing breaks the photo page.

Does anyone have any idea how to resolve? I know it’s not ideal to use Syncthing, but everything works fine, just the photo app crashes.

I don’t know how to fetch a more complete log, but what the browser console says is [ERROR] photos: Error fetching files Object { level: "2", app: "photos", uid: "user", error: SyntaxError }

Check your permissions in the photos directory using

Is -la

Syncthing should be www-data for user and group permissions to match nextcloud.

Mount directories as local storage to avoid sync issues or need to scan.

Hi, which Nc version are you using? I am asking because there is a known issue with the photos app on 26.0.1. which should be fixed with 26.0.2.

The problem is any files synced via Syncthing, not the photos. For example, if I sync an via Syncthing the photos app crashes, but if I remove this file, the photos work normally again.

But I ran the command ls -la and the result is this: drwxrws---+ 4 www-data root 39 May 12 21:08 photos.

I’m using 26.0.1. I tried to update via Nextcloud AIO or pull the image from aio-nextcloud:latest but it doesn’t show update and if I use the beta channel I go to version 27. Is there any other way to force the update via docker?

26.0.2 is not release yet.

szaimen I believe that the solution may be in 26.0.2, I updated to beta version 27.0.0 and the photos app is back to normal.

Thank you very much.