Broken ncp arm64 docker cant finish setup wizard

I’m kinda lost
Can’t go through initial setup on the 64bit nextcloudpi docker image
Running it on dietpi 64bit witch I guess is based on the noobos beta 64bit
I run it using
docker run -d -p 4442:4443 -p 442:443 -p 81:80 -v /mnt/700C216E0C213110/nextcloud_data:/data --name nextcloudpi ownyourbits/nextcloudpi-arm64 $
Accessing at said there that I want remote access,
Next i can’t setup port forwarding (that’s ok I set it up manually) and can’t access my noip ddns domain (anyway skipped)(also tried to docker run with the ddns.domain but also didn’t work

At this point I expected a login screen (I read so on the post comments in nextcloudpi site but never show)
then it says finished and give me two options , one to access my web console and one my nextcloud instance the first opens but everything is unusable(the left side panel, the settings gear etc)Only the nextcloudpi link works and the wizard re-run.
The second brings a not accessable page and I change the port to 4442 but can’t access my instance


Did I miss something?

Maybe try without the -arm64
Not sure, but think latest docker image is no longer platform bound.

Note: remove the current container before starting a new one

i had to go to https://myip/activate to fire up the activation first
bad thing is info on nextcloudpi docker stuff is scatered
found that on another article
that plus proper permissions for the external storage