Broken after update to 12.0.5

Could you set the loglevel to “0” (debug), reload the page, do something on the server and post the latest logs of nextcloud.log.

And there are no log entries in the logs under
/var/log/apache2/
?

We are coming to a point, where I believe it is best to open an issue on Github:

The more we try, the more we could make it worse.

I hope you have a backup.

Tried to remove the theming app as per


but no help - reverting back might be a good idea indeed…

@Hartwin Are you willing to share your NC url?
I’d like to check if I can see the same error messages and behavior on your site.

I just noticed for the server of arvi89 that the JS debugger (Firefox web developer tools) doesn’t load anything for his site. Not an expert on that, but seems strange to me, because on my site it instantly gives me a good overview of all loaded js files.

So I’m still sticking with a potential Javascript issue.

And by the way: javascript loads the CSS files.

Nope, I really thought that for a minor version like that there wouldn’t have any problem.
What worries me is that with my logged in browser, even with everything broken, I could read that the instance was empty (while I actually have 17 GB).

Disabling theming doesn’t work, that’s the first thing I’ve tried.

@arvi89: Through the client-app I can still edit and see all data;; so it seems really an interface-issue…

1 Like

I just got a message that told me all files from my instance were deleted. Awesome. This is BS.

(but at least the files are still in my openstack bucket)

We both are using swift, which might play a role here? - I use it as primary storage; do you?

@Schmu Did you get the URL? Any thoughts or guidance? Thank you!

Yeah, that’s my primary storage too. You might be right, this might be related.

Sorry, I know nothing about swift and can’t judge the possible impact here.

@Hartwin No, I didn’t get the URL. I haven’t received any private messages?

There have been some changes to the file nextcloud/lib/private/Template/SCSSCacher.php made by user skjnldsv:
https://github.com/nextcloud/server/commits/stable12/lib/private/Template/SCSSCacher.php
Though the line where the error occurs wasn’t changed, @skjnldsv still maybe able to help here?

Edit: the link gets destroyed by discourse - I put it in as code for now.

@Hartwin on your site it is the same with
ReferenceError: OC is not defined

However the debugger shows the loaded js files.

Just a little guessing: could you check if you have such an alias in your apache config leading to a wrong javascript directory?

And maybe you can just check that too:

I’m using nginx by the way. Not sure if it is a apache related issue. Have there been some updates to apache (or apache modules) today/ yesterday that might have interfered?

I really suggest to open a bug report on github. That way the developers will see you posts. They have much more insights into the code and can help you better and probably quicker.

Logged: https://github.com/nextcloud/server/issues/8041

For me disabling the .htaccess in nextcloud dir solved that issue.
I know this is just a temporary solution but for everybody who needs a solution right now this could solve it.

So there is an issue with the .htaccess file then?
Was it write protected so the updater couldn’t change the file?

I remember that there was a hardening guide in the past (when NC 10 and 11 were the current releases) that suggested to remove write permissions to most of the folders and files in the Nextcloud folder. Additionally to removing write permissions, the ownership for .htaccess and .user.ini should have been changed to root:root. While that caused too much trouble, these suggestions were removed from the Guide.
Just mentioning that in case you installed your server a while ago and might have followed that guide in the past.

The .htaccess file did not make any difference in my case at least…
I am reverting back to 12.0.4

If you have cli access could you try:

  1. Remove the css and js folder from your appdata_* folder
  2. Run: ./occ files:scan-app-data
  3. Do a force refresh in your browser ctrl + F5

That should force regeneration of all cached JS and CSS files.

2 Likes

So the team has still not fixed the bug, while all users using swift as main storage have had their instance completely broken. We don’t even know if they are working on it (the last contact was 5 days ago on GitHub), I’m seriously considering moving to something else, this is a major issue and they are dealing with it like it’s nothing.

So for all Swift users, this problem has been fixed. Please read this comment to find the fixes for the different Nextcloud versions. The fix is very easy to apply:

1 Like

I had similar issues when default storage was Amazon S3 object store. I wasn’t even able to upgrade from 12.0.3 to 12.0.4 and beyond. I fixed it by adding the following three lines to my config file insidee the objectstore array:

'use_ssl' => true, 
'use_path_style' => true,
'region' => 'us-east-1',  //MY bucket was in this region. Change appropriately, this is the key setting

I hope this helps some one.