Blank Page after Update to NC 17.0.1 an wrong Base-URL (always including /core/)

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 17.0.1
Operating system and version (eg, Ubuntu 17.04): ?
Apache or nginx version (eg, Apache 2.4.25): Apache v. ?
PHP version (eg, 7.1): 7.2

The issue you are facing:
After the Update to 17.0.1 (maybe even at the update to 17.0) NC worked fine but after a short time (I can’t say when) - I only see a white page when I open the Web-URL and the Sync-Client can’t connect anymore.
It looks like the “Base-URL” changed. My normal URL was and now everything is redirected to
When I remove /core/ from the URL some pages load, others won’t.
Where can I change this Base-URL?

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Update from 17.0 to 17.0.1

The output of your Nextcloud log in Admin > Logging:

not accessable

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => '***',
  'passwordsalt' => '***',
  'secret' => '***',
  'trusted_domains' => 
  array (
    0 => '***',
    1 => '***',
  'datadirectory' => '/home/nextcloud-data',
  'overwrite.cli.url' => 'http://next.***.de',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => '***',
  'dbhost' => '***',
  'dbport' => '',
  'dbtableprefix' => '***',
  'dbuser' => '***',
  'dbpassword' => '***',
  'logtimezone' => 'UTC',
  'installed' => true,
  'singleuser' => false,
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 0,
  '' => 'stable',
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_from_address' => 'cloud',
  'mail_domain' => '***',
  'mail_smtphost' => '***',
  'mail_smtpport' => '465',
  'mail_smtpauth' => 1,
  'trashbin_retention_obligation' => 90,
  'twofactor_enforced' => 'false',
  'twofactor_enforced_groups' => 
  array (
  'twofactor_enforced_excluded_groups' => 
  array (
  'mail_smtpname' => '***',
  'mail_smtppassword' => '***',
  'has_rebuilt_cache' => true,
  'app_install_overwrite' => 
  array (
    0 => 'occweb',
    1 => 'bookmarks_fulltextsearch',

The output of your Apache/nginx/system log in /var/log/____:


I have a similar issue: One day after a clean installation, only a blank page was displayed, when entering the Web-URL.
I found out that this is related to nextcloud/core/index.php. When I delete this file, everything is working fine again. Unfortunately this file (Nextcloud/core/index.php) is automatically created every day.
But I do not understand, why it is created again everyday.

Hi, I just had a similar issue (blank screen, but no URL changes). I first thought it had to do with being stuck in maintenance mode (another problem I had previously), so I checked that and came across the upgrade command inside the occ command. So after accessing my Nextcloud instance on DigitalOcean via the (web)console i entered

sudo -u www-data php occ upgrade

which solved my problem. You may have to adapt the command, depending on the distribution you’re using on your server, see the manual under Run occ as your HTTP user

:warning: Disclaimer: I’m very inexperienced/an absolute beginner in all this and I’m essentially just playing around with my own installation, so use at your own risk!
If you try this, let me know if it has worked for you as well.