Blank page after install on raspbian / MariaDB

Hello,

I reinstalled my RaspberryPi over the last day or two, using a raspbian lite image, apache2 and MariaDB, SSL through Let’s Encrypt, DynDNS.
After setting everything up, I browsed to the nextcloud folder and the intallation dialog came up fine. I entered the required stuff and started the installation.
It took a long while so I left my PC up and went for dinner. When I came back, my browser had gone to domain/nextcloud/index.php/apps/files showing a blank page.

Unlike here:


there is no trace of anything wrong in my log, in fact, no new log is being created (I moved the old one from the prior install to a backup). Ok, the file gets created, but it’s just full of one ~ per line.

So… ANY ideas how to get this fixed?

Ok, that was my fault. The DynDNS hadn’t updated yet (cronjob wasn’t set yet).
So that, works now.

OK, now this is becoming a bit of a bother…
I was able to access my server via the internal IP (forwarding through DynDNS hasn’t worked properly for me ever since we switched provided… topic for another day) and was able to add two users. Then I brought up the admin panel which recommended setting some stuff regards opcache in php.ini. I did that, restarted apache… all fine.
There was also a warning about max-age in https strict transport security. I added the recommended setting to my apache config, restarted the service… suddenly, white page syndrome again.

Oh well, shrug restore original apache setting… still white page. Reboot, no dice. Now, best of all: nextcloud.log won’t even get created anymore when I try and access my nextcloud. The last error (before moving the file to easier check what’s happening) is about a wrong password used by my wife, no big deal.

So, I’m stumped again…

Turns out, setting open_basedir in php.ini broke things. I tried adding more and more directories to it, but in the end caved in and commented the whole thing out. Not good enough…
Trying to log into the web interface I get nothing. A long while of “waiting” in the browser, then back at the login (at the URL Domain//index.php/login?redirect_url=/nextcloud/index.php/apps/files/ for some reason)

Strangely, there isn’t a hint about the login attempt in either nextcloud.log nor apache/access.log for the web login, but regular notes about our two desktop sync clients trying to log on in apache/access.log

(sorry for turning this into a long blog, almost)