Blank Dashboard page after 19.x to 20 upgrade

I’m using the Nextcloud VM based on Ubuntu 20.04. I upgraded from I believe 19.3. I logged in to the web interface which gave me the path to an upgrade script. For some reason history isn’t showing me, but I believe it was /var/scripts/

I ran through that and it eventually finished. After reboot I get the login screen and am able to successfully log in. Upon login the page it blank. I started searching around to see what I could find for issues and made a few changes that I don’t think necessarily helped. At some point during testing I happened to notice that if my mouse was near the top of the blank page, but where the links to the sub apps would be, I could see that the browser would show the path for the links in the bottom left. I clicked one and it loaded up and looked completely as it should be. I can go to settings, other apps, etc. and it all loads up as expected. If I go back to the ‘Dashboard’ page, back to a completely blank white screen. I can still click where ‘Files’ etc. would be to get those pages open and functional. Therefore it seems the only page with an issue is the ‘Dashboard’ page. Any idea what my be causing just this page to fail?

I had initially looked at the apache logs and one relevant error I found was:

Connection refused: AH0254: FCGI: attempt to connect to Unix domain socket /run/php/php7.4-fpm.nextcloud.sock (*) failed.

I looked and that file existed and was owned by www-data so that seemed to be in order. On a whim I tried to chmod 777 just as a test on the file, then restarted the php7.4-fpm and apache2 services. Though the permissions seem to have reverted, after the reboot those connection refused errors didn’t/don’t show up anymore. It was after that I found the behavior I mentioned above, so I don’t know if what I did actually fixed anything. I’m not sure where to look next, since apparently most everything is actually working.



I’ve created this account only to give you a solution for your problem. I had the same problem and found on github the solution.
You have to active the “Accessibility” App. After activation, it’s working.

Best regards


Server issue with PR for fix:


That fixed it, thanks!!!

I’ve created this account only to thank you :grin:


Alternatively, deactivate the app “Dashboard”. Seems it depends on Accessibility.

THANK YOU. I spent the night trying to understand that (I thought it was related to 2FA)

That fixed it for us. Thank you!

Maybe I am not smart enough to activate an app. Running these commands showed me the app was already installed and enabled and did not change anything.

$ docker exec --user 33 nextcloud /var/www/html/occ app:install accessibility
accessibility already installed
$ docker exec --user 33 nextcloud /var/www/html/occ app:enable accessibility
accessibility already enabled

Activating the app via UI does not work - it is all blank…