Blank apps page in Nextcloud 17.0.2


This error may be very common but haven’t been able to solve it.
I installed NC manually including all post-install security warnings, except this error.

When I go into any apps page to install one, page is empty. Example addresses:



Searched for permissions issue, etc. any help would be appreciated. I installed NGINX, Php 7.3 and mariadb.


1 Like


Same issue here.
I also tried without the nextcloudPi image and had the same issue.
I have a reverse proxy on another raspberry for https support. I don’t know if it can come from there.

You must be able to connect to the app-store. If you are behind a proxy, check if a direct connection is possible. Also check the logfiles, they should tell you if there is a problem.

If it was working before, and it is just the upgrade to NC 17.0.2, this could be a bug… but we need more information to confirm this.

I saw nothing in the logs indicating a block from the application.

I can curl from the host.

Trying to install nc16 now to see if that makes a difference.

Its the first time i install, never worked for me before.

It is impossible that nobody has gone through this problem, i installed latest version of NC and common LEMP software. I know some people uses installation scripts, docker, etc. but still anyone installing by hand? (best way in my opinion, when other methods fail).


I am having the same trouble with my system running 17.0.2
The apps pages for all categories are blank
the apps included are available
I just installed the parts pgp that wanted to be installed.
All other pages work fine

I found on another page in the support.
If you hold down the shift button and hit he browsers refresh then the apps show up.
I was just able to install apps on my new NC server.

I am having the same problem as of the upgrade.
I am not behind a proxy, and did attempt the shift-refresh suggestion.
No resolution so far.

Leaving another message to say that the issue is now resolved. I don’t know what happened. :o
I made some changes that were suggested in administration/overview:


After a couple of hours, I re-checked the apps page in order to try to troubleshoot more, and now the apps show up.
I will post again if it changes.

Same issue here, after upgrading to 17.0.2, as suggested here I waited 12h but the issue didn’t resolve itself

@Salva_Jimenez I installed it by hand with nginx

It works now, did nothing to fix it

Things that work alone and don’t know why, sometimes happens.

It seems web app can’t connect to apps store for some reason.

I setup nginx.conf file according nc reccomendations. Probably a nginx error (may be most people still use apache and therefore not as tested as nginx).

Can It be debugged somehow? curl or other tool?



Quick note that I saw this on 18.0.3. I enabled logging and saw the following in nextcloud.log:

“app”:“appstoreFetcher”,“method”:“GET”,“url”:"/nextcloud/index.php/settings/apps/list",“message”:“Could not connect to appstore: cURL error 28: Operation timed out after 10000 milliseconds with 3235840 out of 4583501 bytes received (see”

Does this just mean my connection is too slow?

This issue is because this component of nextcloud fetches the apps from the app store. My internet today is flaky therefore it timesout collecting the latest apps. There should be an error message but instead a blank page is produced.