Birthday Calendar isn't synced to the normal calendar because the sync thinks Birthday calendars are disabled

I was wondering why the birthdays of my contacts aren’t being shown in my calendar, so I ran a manual sync on the command-line to see what the problem was.

occ dav:sync-birthday-calendar Hydranet

Then I got the following output/error:
In SyncBirthdayCalendar.php line 119:

Birthday calendars are disabled

I checked that file and a few lines above there(line 116) it shows what it checks for:
$isEnabled = $this->config->getAppValue(‘dav’, ‘generateBirthdayCalendar’, ‘yes’);

I went to check the database table for this user to verify the settings are correct:
±--------±------±-------------------------±------------+
| userid | appid | configkey | configvalue |
±--------±------±-------------------------±------------+
| Hydranet | dav | generateBirthdayCalendar | yes |
±--------±------±-------------------------±------------+

Nextcloud version (eg, 20.0.5): 25.0.3
Calendar App version: 4.2.3
Operating system and version (eg, Ubuntu 20.04): RHEL9.1
Apache or nginx version (eg, Apache 2.4.25): apache 2.4.53
PHP version (eg, 7.4): 8.1

This hasn’t worked in a long time and I didn’t notice it until now, does anybody know how to fix this or has anyone else run into this problem?

I dunno how to help you here…
But I might offer a workaround to you.

I have setup a birthday calendar of my own… and am syncing this one like a normal calendar.

So you ran into the same issue as me? A solution is preferred but if I don’t get a solution a workaround would be good enough. How did you setup your workaround with a separate calendar as a birthday calendar or do you mean that you setup a separate calendar and put the bithdays there and that you sync both that one and your personal calendar?

exactly.

If I ran into the same problems? I dunno… I just had way more birthdays in my calendar than contacts. And so this automated b-day-calendar was never any option for me.

And yes… I did set it up as a completely separate calendar (btw: I think you could set up as much as you like)… put the birthdays there (maybe you can even copy them from auto-birthday-calendar to newly setup calendar?). it works really without any problems. since years.

I figured out the problem it seems I didn’t have a slider enabled under Admin Settings → Groupware, “Automatically generate birthday calendar”. The strange thing was that I did have a birthday calendar before, the only thing I can guess it that it something changed over how it used to be done because I can’t remember ever having to configure it like that in the past with previous previous installations. I was trying to upload a screenshot but seems I don’t have enough posts yet in order to do that, so here’s a link.

So my problem is solved, thanks for your reply and workaround idea anyways @JimmyKater!

@Hydranet perfect. I mean… your solution.

Would never have guessed that a B-day calendar could work without being enabled. If you might wanna do devs a favour pls head over to github and open an issue for them

thanks

The thing is imported my calendar and contacts from an old installation, so in short the birthday calendar should never be enabled in that situation if that slider is required to actually enable the birthday calendar. Here’s the issue I created.