Bilder innerhalb shared-link Ordner werden nicht angezeigt

Hallo!

Bilder innerhalb shared-link Ordner werden nicht angezeigt.
Wenn ich eingeloggt bin, alles kein Problem.
Habe einen Link zum Ordner weitergegeben, dort werden Bilder/Videos nicht angezeigt,
man muss sie runterladen um sie zu sehen.

Ich bin oft hinter einem VPN, manchmal lösen sich Probleme, wenn ich die Verbindung wechsle.
Aber dieses Problem haben auch andere, die nichts mit VPN machen.

Nextcloud version: 18.0.4 - 18.0.4.2
Operating system: Linux 4.4.0-186-generic #216-Ubuntu SMP Wed Jul 1 05:34:05 UTC 2020 x86_64
Webserver: Apache (fpm-fcgi)
Database: mysql 5.7.28
PHP version: 7.3.17-nmm1
lÀuft auf All-Inkl.com account

The issue you are facing:
Bilder innerhalb shared-link Ordner werden nicht angezeigt

Is this the first time you’ve seen this error? Y

Zum selber probieren

Kurzes Video wie ich es auf versch. Browsern erlebe

The output of your Nextcloud log in ~Admin > Logging~:

War wohl ein Bug in alten 18er-Versionen. Mach ein Update in 18 oder zu 19. Schau https://scan.nextcloud.com

Offtopic:
Das “index.php” kannst du auch noch rauswerfen. Sieht dann schöner aus.
Remove index.php in Url on Litespeed

Falls du Nextcloud-Bilder direkt in HTML einbinden willst schau hier
https://apps.nextcloud.com/apps/sharingpath

Danke!
Werd’s mal angehen


Vielleicht hilft auch das:

@szaimen
Oh ja. War das ein Bug oder ein Feature? Wurde es in Updates behoben? Ich nutze die benötigte Berechtigung sowieso und kenn die Enwicklung bzgl. der Problemstellung nicht.

Weder noch. Das setting muss aktiv sein, damit die Bilder bei einer öffentlichen Freigabe ĂŒber einen Link vom Viewer geladen werden können.

Soweit ich weiß, wurde das noch nicht behoben/verĂ€ndert.

Github:
“Allow users on this server to send shares to other servers”

Am Ende ist bei einem öffentlichen Link vielleicht nur der EmpfĂ€nger wie ein “other server”. Man kann ja auch den Share zu seiner beliebigen Nextcloud hinzufĂŒgen (MenĂŒ oben rechts beim Shared Link). WĂ€re sonst inkonsequent.

Ja also vielen Dank euch beiden,
habe jedenfalls grad nach 19.0.1 geupgraded
und den Haken gesetzt,
und jetzt gehts.
:smiley:

index.php rausgeworfen
 :slight_smile:
Danke!