Bigint-conversion "no www-data user"

Hi there

I’m using a synology with docker for my nextcloud.
I’ve just installed the update 17.0.3 and it gives me the “occ db:convert-filecache-bigint” message.

So naturally I tried using sudo -u www-data php occ db:convert-filecache-bigint .

Sadly though, all I’m getting is a unknown user www-data error.

going through the passwd file, it really isn’t there. I’m not a big crack on linux permissions.
Could anybody provide me with, if that even help, a command that creates and sets all the permissions right for the above mentioned user?

Can anybody please help me out here?

For docker it is local user of docker :slight_smile: , so you have no www-data user in system any more. You have to pass tcommands to the docker first and then run what you want. E.g.:

docker exec --user www-data CONTAINER_ID php occ

Read more about:

Thanks for your answer, but I still get the same message

unable to find user www-data: no matching entries in passwd file

With ID you mean the container name right? Cause I can’t see any specific number

EDIT: I’ve found out that the user I have to use is abc ( Docker image). But after that this message appears
Could not open input file: occ

But this did the trick
sudo -u abc php /config/www/nextcloud/occ db:convert-filecache-bigint

1 Like