Benötige bitte Hilfe bei der Installation

Liebe Linux & Nextcloud Profis,
ich habe nun komplette 2 Tage bis tief in die Nacht versucht Nextcloud zu installieren, bzw. so dass es ohne Fehlermeldungen ist.
Die Fehler sind folgende:
~ HTTP-Header ist nicht gesetzt (er sollte mindestens 15552000 Sekunden betragen
~ Der Server hat keine konfigurierte Startzeit fĂŒr das Wartungsfenster
~ In der Datenbank fehlen einige Indizes.
~ Es wurde kein Speichercache konfiguriert.
~ Das PHP-Modul “imagick” in dieser Instanz hat keine SVG-UnterstĂŒtzung
~ konfiguriere bitte Memcache

Allein um das Problem mit der Datenbank “occ db:add-missing-indices” zu lösen habe ich schon bis zur Verzweiflung gekĂ€mpft.
SÀmtliche Anleitungen und Lösungen im Web ausprobiert, nichts funktioniert.
Server schon 2 Mal neu installiert, fĂŒr die anderen Probleme die config.php modifiziert wie beschrieben
alles ohne Erfolg.
Fazit, 2 Tage und immer noch am Anfang.
Zuletzt heute neu aufgesetzt, installation nach Anleitung mit Docker ĂŒber Putty versucht, erfolglos.
Kann mir jemand helfen und Nextcloud auf meinem Server installieren ?
Ich bezahle dafĂŒr
ansonsten gebe ich auf.
LG Mike

Distributor ID: Ubuntu
Description: Ubuntu 22.04.4 LTS
Betriebssystem: Linux 5.15.0-113-generic x86_64

Nextcloud Hub 8 (29.0.3)

docker0
Status: up
Geschwindigkeit: unknown (Duplex: unknown)
IPv4: 172.17.0.1

PHP
Version: 8.2.20

Speicherlimit: 512 MB
Maximale AusfĂŒhrungszeit: 3600
Maximale GrĂ¶ĂŸe zum Hochladen: 1,6 GB
OPcache-RevalidierungshÀufigkeit: 2
Erweiterungen: Core, date, libxml, openssl, pcre, zlib, bz2, calendar, ctype, hash, filter, ftp, gettext, gmp, json, iconv, SPL, random, Reflection, session, standard, mbstring, SimpleXML, sockets, tokenizer, xml, cgi-fcgi, mysqlnd, bcmath, curl, dba, dom, enchant, fileinfo, gd, imagick, imap, intl, ldap, exif, mysqli, odbc, PDO, pdo_mysql, PDO_ODBC, pdo_pgsql, pdo_sqlite, pgsql, Phar, posix, pspell, redis, soap, sodium, sqlite3, sysvmsg, sysvsem, sysvshm, tidy, xmlreader, xmlwriter, xsl, zip, Zend OPcache

DB _ Art: mysql
Version: 10.6.18
GrĂ¶ĂŸe: 8,8 MB

Zu den Hinweisen gibt es in der Regel auch Links auf die Seiten, die sich mit diesem Thema befassen.
Aber auch die Forensuche nach SchlĂŒsselwörtern Deiner Fehlermeldungen/-hinweise hilft:

https://docs.nextcloud.com/server/latest/admin_manual/installation/harden_server.html#enable-hsts-label

"occ db:add-missing-indices" -bash: occ: Kommando nicht Gefunden (avchte auch auf die BeitrÀge unter der Lösung)

Auf englisch: memory-cache:
https://docs.nextcloud.com/server/latest/admin_manual/configuration_server/caching_configuration.html

https://docs.nextcloud.com/server/latest/admin_manual/configuration_server/theming.html

Detailliertere Informationen kann ich nicht liefern, da Du Deine Installationsmethode und Konfiguration geheim gehalten hast.

Wenn alles lÀuft kann auch was kaputt gehen. Daher ist Know How wichtig. Zwei Tage sind da noch sehr kurz.

Starte evtl. fĂŒr wichtige Daten mit einer Managed Nextcloud im Internet. Teste zuhause weiter und werde immer besser.

Danke fĂŒr Deine Antwort.
Leider habe ich das schon alles durch, einige Befehle wie "
sudo -u www-data php occ db:add-missing-indices" kann ich schon auswendig in 10 verschiedenen Varianten, mit PHP Version, kompletten Pfad oder direkt im Verzeichnis, ich habe sÀmtliche Infos gesucht und jede Idee ausprobiert, nicht hat geklappt.
Es ist ein VServer (Strato), event liegt es daran.
Nextcloud lĂ€uft, stĂŒrzt aber ab und zu ab und der Server ist komplett down.

Fakt ist ich habe zu wenig Ahnung von Linux oder sagen wir besser keine, ich dachte ich installiere ein fertiges Produkt.
Nextcloud ist echt geil, ich wĂŒrde ungern darauf verzichten weil eine echte Alternative gibt es nicht.

Vieleicht erbarmt sich ja jemand und installiert mir Nextcloud, gebe gerne alle Zugangsdaten fĂŒr die Installation.

~Mike

Schau mal bei decatec.de und oder bei C.rieger vorbei. Dort wird alles erklÀrt
 auch Datensicherung und alles drumherum

ich sehe, du willst NC in einem Docker installieren?

Warum greifst du dann nicht zu NC All-in-one? Das ist auch per Docker realisiert. Und es ĂŒbernimmt große Teile der Installation fĂŒr dich.

Ein Problem der bisherigen könnte sich lösen, indem du deine OCC-Kommandos im entsprechenden Docker-container ausfĂŒhrst
 Wie? Das weiß das Manual.

1 Like

Das war heute mein Plan, habe den Server neu aufgesetzt und dann alles step by step mit Putty installiert, also inklusive Docker. Dann gab es eine Fehlermeldung wegen “Container” und nichts ging mehr.
Denke die Anleitung war auch falsch bzw veraltet.(Strato)
Ich wollte Docker nutzen um das Problem mit der Datenbank zu lösen, habe mehrfach gelesen das es damit funktioniert.
Mal eine Frage zu den fehlenden Datenbank eintrĂ€gen, warum gibt es die fehlenden DatensĂ€tze nicht irgendwo zum download, sollte ja kein Problem sein diese mit PHPMyAdmin einzufĂŒgen bzw habe ich das vor Jahren meistens so gemacht.

Bei Docker-Instanzen sieht es natĂŒrlich anders aus:
docker -exec sudo -u www-data php /path/to-occ/occ db:add-missing-indices

leider kommen die Infos nur hÀppchenweise.

Datenbank Problem einfach gelöst !
Da alle fehlenden Datenbank Tabellen von “MAIL” stammten habe ich diese APP entfernt und mit Snappy Mail ersetzt. Siehe da, keine Fehlermeldung mehr mit Bezug auf die Datenbank. :+1:

Jetzt wĂŒrde ich gerne dieses kleine Problem noch lösen:
Einige Header sind in deiner Instanz nicht richtig eingestellt - Der Strict-Transport-Security-HTTP-Header ist nicht gesetzt (er sollte mindestens 15552000 Sekunden betragen).
Das habe ich heute schon mehrfach versucht, gibt es dafĂŒr eine genaue Anleitung wo die entsprechenden EintrĂ€ge zu machen sind ?

Wo genau kommt dieser Eintrag rein bitte ?
<VirtualHost *:443>
ServerName cloud.nextcloud.com

Header always set Strict-Transport-Security “max-age=15552000; includeSubDomains”

In die conf-Datei, die in /etc/apache2/sites-enabled auf Port 443 konfiguriert ist.
Je nach System kann es die default-ssl- conf sein oder eben eine andere.
Durt werden einfach die drei Zeilen aus der oben von mir verlinkten Anleitung eingefĂŒgt.

Bei Nginx-Webservern sieht die Syntax möglicherweise etwas anders aus.

Hallo und danke fĂŒr die Info,

habe das nun nacheinander eingetragen in die:
default-conf, default-ssl.conf,
Server neu gestartet, keine Änderung, keine Probleme.

Danach eingetragen in:
/etc/apache2/sites-enabled/ default-conf, default-ssl.conf
keine Änderung.

Danach eingetragen in:
etc/apache2/sites-available/

Keine Änderung, server lĂ€uft ohne Probleme.
In Nextcloud immer noch: inige Header sind in deiner Instanz nicht richtig eingestellt - Der Strict-Transport-Security-HTTP-Header ist nicht gesetzt (er sollte mindestens 15552000 Sekunden betragen).

:rofl:

root@stoic-mclaren:/etc/apache2# ls -r
 sites-enabled     mods-enabled     conf-available
 sites-available   mods-available  'apache2.conf.saved_by_psa.06.29;08:23'
 ports.conf        magic           'apache2.conf.saved_by_psa.06.29;08:12'
 plesk.conf.d      envvars          apache2.conf
 modsecurity.d     conf-enabled
root@stoic-mclaren:/etc/apache2# cd sites-available
root@stoic-mclaren:/etc/apache2/sites-available# ls -r
default-ssl.conf  000-default.conf
root@stoic-mclaren:/etc/apache2/sites-available# vi 000-default.conf
root@stoic-mclaren:/etc/apache2/sites-available# vi 000-ssl.conf
root@stoic-mclaren:/etc/apache2/sites-available# vi 000-default-ssl.conf
root@stoic-mclaren:/etc/apache2/sites-available# cd sites-enabled
-bash: cd: sites-enabled: No such file or directory
root@stoic-mclaren:/etc/apache2/sites-available# ls -r
default-ssl.conf  000-default.conf
root@stoic-mclaren:/etc/apache2/sites-available# vi default-ssl.conf
root@stoic-mclaren:/etc/apache2/sites-available# ls -r
default-ssl.conf  000-default.conf
root@stoic-mclaren:/etc/apache2/sites-available# vi default-ssl.conf
root@stoic-mclaren:/etc/apache2/sites-available# vi 000-default.conf

Interessant wÀre zu wissen, WAS Du eingetragen hast. Du tust immer noch so, alsa wÀre es ein Staatsgeheimnis.

Meine default-ssl-conf sieht so aus:

<VirtualHost *:443>
        <IfModule mod_headers.c>
                Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains"
        </IfModule>

        IncludeOptional /etc/apache2/ucs-sites.conf.d/*.conf
        SSLEngine on
        SSLProxyEngine on
        ...

2 posts were split to a new topic: Nach Upload von 5 Fotos → Absturz

A post was merged into an existing topic: Nach Upload von 5 Fotos → Absturz

Nextcloud nun komplett ohne Fehlermeldung.

das ist doch super!

Gabs etwas, was dir besonders geholfen hat oder am meisten? Dann setz bitte da den “gelöst”-Haken.
Oder schreibe selbst hier etwas ausfĂŒhrlicher ĂŒber die Lösung(en) und verdiene dir deinen ersten Lösungshaken selbst

Danke fĂŒr Eure Hilfe.
Ich habe alle Probleme gelöst und Nextcloud lÀuft absolut zuverlÀssig.
Google Drive Integration lÀuft inzwischen auch Problemlos.
Kleiner Tip, legt immer einen zweiten Admin an zur Sicherheit, nach Passworwechsel hatte ich da ein kleines Problem, aber auch das habe ich gelöst.
File upload problem war eine “open_basedir” BeschrĂ€nkung, nun kann man ohne probleme 2GB files hochladen.
Ich bin Linux Noob, musste mich in jedes problem erst einlesen aber am Ende hat alles funktioniert.

VIELEN DANK AN ALLE
Gruß Mike

1 Like