Bekomme Nextcloud 27 nicht aus dem Debug-Modus

Hallo Gruppe

Ich habe meine Nextcloud von V25 auf V27 aktualisiert (über die Weboberfläche, mit Zwischenschritt über V26)
Jetzt steht bei mir unter den Sicherheits- & Einrichtungswarnungen, das meine Instanz im Debug-Modus ausgeführt wird.
Gibt es ausser der config.php noch eine andere Möglichkeit, die NC in den Debugmodus zu versetzen? Denn hier steht " ‘debug’ => ‘false’, ", so dass sich meine NC eigentlich nicht im Debug-Modus befinden sollte…

Gruß
Steffen

System:
Nextcloud: 27.1.1
Server: VM auf VMware-Server bei uns
OS: Ubuntu 22.04.3
Webserver: Apache 2.4.52
PHP: php 8.1.2
DB: MariaDB 10.6.12

Hallo @steffen0377 ,

willkommen in den Foren der Anwender-Gemeinschaft von Nextcloud!

soweit ich weiß, gibt es nur diesen Parameter.
Doku siehe

https://docs.nextcloud.com/server/latest/admin_manual/configuration_server/config_sample_php_parameters.html?highlight=debug#debug

Andere Idee: Hast Du den Eintrag vielleicht mehrfach in Deiner config.php?

Gruß

Hallo @rakekniven,

nein, habe das nicht doppelt drin, das habe ich bereits überprüft. Aber ich habe gerade die Lösung gefunden :slight_smile:

Es sind die einfachen Anführungszeichen gewesen.
falsch: ‘debug’ => ‘false’,
richtig: ‘debug’ => false,

Hat so in der Vergangenheit funktioniert, habe ich auch nie geändert. Habe aber weiter unten in der config.php bei anderen Werten gesehen, dass dort die Bool-Werte ohne die Anführungszeichen standen. Manchmal muss man einfach nur über das Problem reden, dann findet man die Lösung selber.

1 Like