Basic snap install on current Ubuntu, apparently successful, but seemingly dead

I just installed Nextcloud in a snap on a Kubuntu 20.04.1 LTS. It appears that that installation succeeded, as snap reports the following:

root@[myhostname]:/var/snap/nextcloud# snap services nextcloud
Service                    Startup  Current  Notes
nextcloud.apache           enabled  active   -
nextcloud.mdns-publisher   enabled  active   -
nextcloud.mysql            enabled  active   -
nextcloud.nextcloud-cron   enabled  active   -
nextcloud.nextcloud-fixer  enabled  active   -
nextcloud.php-fpm          enabled  active   -
nextcloud.redis-server     enabled  active   -
nextcloud.renew-certs      enabled  active   -

At this point, I created an admin account and set its password by running:
root@[myhostname]: nextcloud.manual-install admin arealpassword

Per the instructions, I added my several machines’ IPv4 addresses as trusted domains. That also appears to have worked, and the relevant entries now appear in /var/snap/nextcloud/current/nextcloud/config/config.php.

array (
        0 => 'localhost',
        1 => '[correct_ip_address1]',
        2 => '[correct_ip_address2]',
        3 => '[correct_ip_address3]',

I restarted the nextcloud.apache service at this point, which again, appears to have been successful per snap services.

The documentation leads me to believe that at this point, I should be able to access http://[myhostname] and see something, anything, from Nextcloud. But I do not. All I see at that address is the default Apache start page. https://[myhostname] refuses the connection, and http://[myhostname]/nextcloud is not found.

Can anyone tell me why my Nextcloud snap appears dead as a doornail? Or what else to check?

Nothing of import appears in any log under /var/snap/nextcloud or the output of ‘snap logs nextcloud’. I checked the FAQ at How-to/FAQ WIKI to no avail and searched this forum with the same result.

Thanks in advance.

One additional note, I do get this line-noise of a message in /var/snap/nextcloud/23027/apache/logs/php_errors.log I’ve no idea what it could mean nor if it’s relevant, so if anyone can make sense of this, please do.

[09-Sep-2020 06:49:42 UTC] {"reqId":"YrmXmnnHPCyOzvoOZJDM","level":3,"time":"2020-09-09T06:49:42+00:00","remoteAddr":"","user
":"--","app":"cron","method":"","url":"--","message":{"Exception":"Exception","Message":"Not installed","Code":0,"Trace":[{"f

Nice format on that error message.