Basic problems setting up NCP on a RPi4

New to the forum, Nextcloudpi and the Raspberry Pi! So I just followed the directions for booting NCpi from a usb3 SSD connected to a Raspberry pi4. This is a clean install and I have nothing to backup. Everything appeared to go smoothly, but I can not connect to the https://nextcloudpi.local. I cant seem find a solution on the internets. Thanks for the help.

try https://your.local.ip:4443

Thanks for quick reply; and sorry for the short post lacking some details. So just to clarify, I started completely from scratch here. I bought the RPI4, installed Raspbian on a SD card and followed the directions posted here: NextCloudPi on Raspberry PI 4 – Booting from USB Device (no microSD) | NextCloudPi Documentation. I connected to the Pi4 via SSH and updated everything mentioned in the directions. The NCpi image was flashed successfully. After booting the Pi4 up with out the SD card installed and the SSD attached I cant connect to the SSD to finish setting up NCpi. (still can not connect with either option you posted Jimmy). Since this is literally the first thing I tried to do with the Pi4 is there anything I’m missing that might not be posted in the directions? I Do I need to mount the SSD? With the SD card installed I can see the SSD attached. Do these directions assume you’ve all ready had Nextcloud up and running? Thanks for your help and patience.

I’m stuck here too, has anyone else encountered this? I flashed a clean image onto an empty usb3.1 drive and it boots, but wont let me ssh in and the nextcloudpi.local page is a 503 service unavailable

you have to enable ssh first
https://docs.nextcloudpi.com/en/how-to-enable-ssh-using-nextcloudpi-config-or-ncp-web/

actually not.

And to my knowledge I did not leave anything out.

What confuses me is why you still talk about a SD card. You should not need that any more.

Check your router, does the Pi appear as connected?
If yes, you should be able to connect with that ip to the activation panel.

If you still fail try to flash the image again to the USB Drive.

I tested this multiple times and it always worked.

No, I just used the SD card for initial setup as described in the directions. The thing was, once I tried to boot from the flashed SSD I couldn’t see the Rpi4 IP address as I did when the SD card was installed. I also couldn’t connect the other ways suggested as well. So I decided to see if mounting the SSD would make a difference, and it did to a certain extent. I can now see the Rpi4 IP on my modem homepage, but I still can not connect any of the ways mentioned. I’ve also flashed the image to the SSD a couple of times.

Sorry for not showing up…
Hope you already found a solution. If not:

If you remove the SD card and only boot with the SSD, does the green LED on the Pi do something (blinking)?


I assume you did that, as you say that you followed the guide, but just in case:
Check what version of the eeprom you have.

use a image on the SD card and access the terminal to type
sudo rpi-eeprom-update
…if there is an update, update it.

Or, and this might be easier, simply follow these steps:

Raspberry Pi Imager

The easiest way to to update the bootloader to the latest version with default settings is to use the Raspberry Pi Imager to install a boot recovery image onto a spare SD card.

Select “Choose OS -> Misc utility images -> Raspberry Pi 4 EEPROM boot recovery”

Raspberry Pi OS also keeps the EEPROM up-to-date: new EEPROM images are applied when the Raspberry Pi 4 next boots.

If all this does not work, try to flash the image to another SSD or a USB drive, it could be that there is something wrong with the SSD.