Bad UX updating to 28.0.2 [Docker]

I run NC in a Docker container with MariaDB as my backend. Recently I was informed that there was a new version (28.0.2 - I’m currently on 28.0.1). My first gripe… It’s not at all intuitive how to determine what version you currently are on. I’d say for the past 30 years or so we’ve all seen that usually the version number appears in the Help > About dialog. But not with NC! Fancy animation and then a dialog box over the dialog box advertising that you can get NC on all your devices. Lovely. I know that already. Yet no version is to be found! Please make the Help > About dialog box present the actual current running version!

OK so I got over to Administration settings and I see I’m currently on 28.0.1 and that 28.0.2 is available. Great. Under Update there’s a Download now and an Open Updater link. Download now downloads a zip file. What am I supposed to do with that? I assume that’s for people who run NC without Docker.

OK so let’s try this Open updater option… 404! Wonderful!

So how am I supposed to update?!?

What did work:

  1. Stop NC docker container
  2. Delete NC docker container
  3. Delete NC docker image
  4. Pull NC docker image
  5. Recreate NC docker container

Now when I go to NC it has the updater.

BTW: Why does it keep disabling the following very useful apps?

  • cfg_share_links
  • impersonate
  • sharerenamer

???

So, applying the update I get:

Yet reloading the page goes to the main dashboard and Administration settings say I’m now on 28.0.02.

In a few words… not a good UX!

Which image? There are several Nextcloud project maintained ones as well as third-party ones. It matters a great deal. :slight_smile:

If you’re using the micro-services image, the process is the standard Docker image one:

docker compose pull
docker compose up -d

Wait a few seconds.
Done.

Nearly all Docker images document their process on their Docker Hub page - or directly link to their documentation from there[1][2].

In newly deployed images, at least most of the ones I’m aware of - the Web Updater is outright disabled these days (since it’s not appropriate for most of the Docker images). When it’s disabled, the Open Updater button isn’t shown.

It sounds like it’s still on in your environment (maybe from a prior installation still retaining the old config parameter - or an image I’m not familiar with). This is the parameter that needs to be set in your Nextcloud config[3].

BTW: Why does it keep disabling the following very useful apps?

Well at least 2 of those 3 three apps aren’t compatible with Nextcloud v28 from the looks of their app store pages.

Yet reloading the page goes to the main dashboard and Administration settings say I’m now on 28.0.02.

Your Nextcloud Server logs will have the answer. Also, possibly your container logs. It’s not typical, but we’d need more details to help you (image, log entries from the time period of the update, occ config:list system output or equivalent from your container/environment)

[1] GitHub - nextcloud/docker: ⛴ Docker image of Nextcloud

[2] nextcloud - LinuxServer.io

[3] Configuration Parameters — Nextcloud latest Administration Manual latest documentation

I’m on Synology and I use their Container Manager. I’m not shy of the command line but the Container Manager has a nice GUI.

AFAICT I’m using the official one. The image name is simply nextcloud. I do use linuxserver for most of my other Docker images but I went with the official one for NC.

But I don’t use docker compose. I’ve tried it before and had issues. I don’t use docker compose for any of my other docker apps either.

If you have to refer back to something online for individualized steps of how to update something then IMHO your update process is not a good experience for the end user. Here’s a good user experience - Plex. It’s docker app runs just fine. When an update is available you are notified in the web page for Plex. How do you update? Simply restart the container! It does everything necessary to update your image and container. Done. Now that’s a good UX!

Well the Open Update was definitely there and it definitely didn’t work.

There is nothing that I consciously did to configure an update button.

And the 3rd app?

I know the end reason is that they aren’t compatible, but why aren’t they compatible? Seems to me the ability to name a share link with something meaningful should not be that complicated in NC such that each new version breaks them each time. I’ve been to some of their support pages and the best you get is a list of what NC versions they support with the current NC version not being listed. All you can do is wait until they hopefully update their app.

Look it’s a similar situation with Thunderbird and various browsers which offer add ons or extensions and yes sometimes they break as the underlying API gets changed. But usually it’s only for major changes not a 28.0.1 → 28.0.2 update.

My point is that the update process for NC is painful - more painful than most of the docker apps that I run and maintain. Granted, when there’s a problem then digging into the logs and configs is warranted. But just to do a minor update should be a single click or two and it should “just work”. Plex is an example of a good UX. A docker app that sports a web interface should notify the user when an update is available (some don’t) and updating should be simple and as flawless as possible.

Synology’s Container Manager has a mechanism for identifying and updating images and containers that have updates. It largely works. Often the docker app seems to have no discernable difference (version number stays the same). Other times when I go into the docker app’s web interface I’m presented with a dialog saying “What’s new in this version” kinda thing and everything is cool. I try to keep my docker apps all up to date all the time.

I think the issue really is that there are people who develop docker images and know all the CLI tools to do what they want to do to update and develop docker images and containers. And then there are docker app users who just want to use the app. While I’m a developer myself, I’m not into nor trying to be a docker developer at this time on this Synology server. I’m more a docker app user and just want the apps to run and be up to date.