Bad Gateway 502. Nextcloud in Docker with nginx + letscrip in front

Im running a nginx + letsencrip in my local machine like reverse proxy.
I wanna install nextcloud in docker. This is my dockerfile:

version: “3”

image: mariadb
restart: always
command: --transaction-isolation=READ-COMMITTED --binlog-format=ROW
MYSQL_USER: nextcloud
- $HOME/docker-apps/nextcloud/db_data:/var/lib/mysql

    image: nextcloud:fpm
    restart: always
        - db
        - $HOME/docker-apps/nextcloud/nextcloud_data:/var/www/html
        MYSQL_DATABASE: nextcloud
        MYSQL_USER: nextcloud
        MYSQL_PASSWORD: mypass
        MYSQL_HOST: db

And this is my nginx config file

upstream php-handler {


server unix:/var/run/php/php7.4-fpm.sock;


server {
listen 80;
listen [::]:80;
# enforce https
return 301 https://$server_name$request_uri;

server {
listen 443 ssl http2;
listen [::]:443 ssl http2;
access_log /var/log/nginx/nextcloud_access.log;
error_log /var/log/nginx/nextcloud_error.log;

# Use Mozilla's guidelines for SSL/TLS settings
# NOTE: some settings below might be redundant

ssl_certificate /etc/letsencrypt/live/; # managed by Certbot
ssl_certificate_key /etc/letsencrypt/live/; # managed by Certbot
ssl_trusted_certificate /etc/letsencrypt/live/;
include /etc/nginx/snippets/ssl.conf;

add_header Referrer-Policy "no-referrer" always;

Remove X-Powered-By, which is an information leak

fastcgi_hide_header X-Powered-By;

# Path to the root of your installation
root /home/linux_user/docker-apps/nextcloud/nextcloud_data;

location = /robots.txt {
    allow all;
    log_not_found off;
    access_log off;

# The following 2 rules are only needed for the user_webfinger app.
# Uncomment it if you're planning to use this app.
#rewrite ^/.well-known/host-meta /public.php?service=host-meta last;
#rewrite ^/.well-known/host-meta.json /public.php?service=host-meta-json last;

# The following rule is only needed for the Social app.
# Uncomment it if you're planning to use this app.
#rewrite ^/.well-known/webfinger /public.php?service=webfinger last;

location = /.well-known/carddav {
  return 301 $scheme://$host:$server_port/remote.php/dav;
location = /.well-known/caldav {
  return 301 $scheme://$host:$server_port/remote.php/dav;

# set max upload size

fastcgi_buffers 64 4K;

# Enable gzip but do not remove ETag headers
gzip on;
gzip_vary on;
gzip_comp_level 4;
gzip_min_length 256;
gzip_proxied expired no-cache no-store private no_last_modified no_etag auth;
gzip_types application/atom+xml application/javascript application/json application/ld+json application/manifest+json application/rss+xml application/vnd.geo+json application/ application/x-font-ttf application/x-web-app-manifest+json application/xhtml+xml application/xml font/opentype image/bmp image/svg+xml image/x-icon text/cache-manifest text/css text/plain text/vcard text/vnd.rim.location.xloc text/vtt text/x-component text/x-cross-domain-policy;

# Uncomment if your server is build with the ngx_pagespeed module
# This module is currently not supported.
#pagespeed off;

location / {
    rewrite ^ /index.php;

location ~ ^\/(?:build|tests|config|lib|3rdparty|templates|data)\/ {
    deny all;
location ~ ^\/(?:\.|autotest|occ|issue|indie|db_|console) {
    deny all;

 location ~ ^\/(?:index|remote|public|cron|core\/ajax\/update|status|ocs\/v[12]|updater\/.+|oc[ms]-provider\/.+|.+\/richdocumentscode\/proxy)\.php(?:$|\/) {
    fastcgi_split_path_info ^(.+?\.php)(\/.*|)$;
    set $path_info $fastcgi_path_info;
    try_files $fastcgi_script_name =404;
    include fastcgi_params;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_param PATH_INFO $path_info;
    fastcgi_param HTTPS on;
    # Avoid sending the security headers twice
    fastcgi_param modHeadersAvailable true;
    # Enable pretty urls
    fastcgi_param front_controller_active true;
    fastcgi_pass php-handler;
    fastcgi_intercept_errors on;
    fastcgi_request_buffering off;

location ~ ^\/(?:updater|oc[ms]-provider)(?:$|\/) {
    try_files $uri/ =404;
    index index.php;

# Adding the cache control header for js, css and map files
# Make sure it is BELOW the PHP block
location ~ \.(?:css|js|woff2?|svg|gif|map)$ {
    try_files $uri /index.php$request_uri;
    add_header Cache-Control "public, max-age=15778463";
    # Add headers to serve security related headers (It is intended to
    # have those duplicated to the ones above)
    # Before enabling Strict-Transport-Security headers please read into
    # this topic first.
    #add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;" always;
    # WARNING: Only add the preload option once you read about
    # the consequences in This option
    # will add the domain to a hardcoded list that is shipped
    # in all major browsers and getting removed from this list
    # could take several months.
    add_header Referrer-Policy "no-referrer" always;
    add_header X-Content-Type-Options "nosniff" always;
    add_header X-Download-Options "noopen" always;
    add_header X-Frame-Options "SAMEORIGIN" always;
    add_header X-Permitted-Cross-Domain-Policies "none" always;
    add_header X-Robots-Tag "none" always;
    add_header X-XSS-Protection "1; mode=block" always;
# Optional: Don't log access to assets
    access_log off;

location ~ \.(?:png|html|ttf|ico|jpg|jpeg|bcmap|mp4|webm)$ {
    try_files $uri /index.php$request_uri;
    # Optional: Don't log access to other assets
    access_log off;


But when im trying to access the netxloud it shows me
“502 ERROR”

I dont see any error in /var/log/nginx

Can you help me please?

Hi Eladio,

did you add server name to your nextcloud config file?? This may be the reason you are getting the error.

i doubt that your nginx will find php-fpm at this socket.

did you have a look at the example docker-compose file?