Background tasks in the cron job does not work

Hello everyone!
What needs to be changed? The background tasks in the cron job are not processed correctly

This is the output from the terminal:

root@xxxxxserver:~# sudo -u www-data php -f /var/www/html/nextcloud/cron.php
PHP Fatal error:  Allowed memory size of 2097152 bytes exhausted (tried to allocate 438272 bytes) in /var/www/html/nextcloud/3rdparty/composer/autoload_real.php on line 37

Nextcloud version (eg, 20.0.5): 23.0.0
Operating system and version (eg, Ubuntu 20.04): Debian 11.2
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.52
PHP version (eg, 7.4): php8.0

thanks in advance

Check your memory settings in your php.ini file. I bet they are too low. You can do a search on internet for that.

Thanks, I forgot an “M”!

1 Like

When I first installed NC I spent probably two days (off and on) trying to figure out what was wrong with my setup. I finally found that I missed a " ’ " in the config.php file for mem cache . lol.