Available updates not showing - 24.0.7

I installed 24.0.7 at the end of last year and everything has been working great on the server. I have regularly checked (monthly) for updates when I check all my servers for updates and there has never been an update available. I realize that the latest release is sometimes released in phases to slow down adoption but this is not the case. 24.0.9 came out 3 weeks ago and 24.0.8 came out 6 weeks before that - that is not taking into account that 25 has been out since November, 2022 (3 full months ago).

I am able to update all other aspects of my server:
Ubuntu Linux 22.04.1
Apache version 2.4.52
MariaDB version 10.6.11
PHP version 8.1

Any time I try to update my server it always states “Your version is up to date.” and shows the current date and time as the last time the server has been checked.

The server is on the Stable channel which certainly seems like it should recognize the newer versions by now. Also today I got an email from the server letting me know “February 7, 2023 at 1:25 PM
The update server could not be reached since 7 days to check for new updates.
Please check the Nextcloud and server log files for errors.”

When I check the Nextcloud logs, I see the following error:
[internet_connection_check] Error: GuzzleHttp\Exception\ConnectException: cURL error 28: Failed to connect to www.nextcloud.com port 80 after 15202 ms: Connection timed out (see libcurl - Error Codes) for http://www.nextcloud.com/ at <>

  1. /var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php line 158
  2. /var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php line 110
  3. /var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/CurlHandler.php line 47
  4. /var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/Proxy.php line 28
  5. /var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Handler/Proxy.php line 48
    GuzzleHttp\Handler\Proxy::GuzzleHttp\Handler{closure}(“*** sensitive parameters replaced ***”)
  6. /var/www/html/nextcloud/lib/private/Http/Client/DnsPinMiddleware.php line 146
    GuzzleHttp\Handler\Proxy::GuzzleHttp\Handler{closure}(“*** sensitive parameters replaced ***”)
  7. /var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/PrepareBodyMiddleware.php line 35
    OC\Http\Client\DnsPinMiddleware->OC\Http\Client{closure}(“*** sensitive parameters replaced ***”)
  8. /var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Middleware.php line 31
  9. /var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/RedirectMiddleware.php line 71
    GuzzleHttp\Middleware::GuzzleHttp{closure}(“*** sensitive parameters replaced ***”)
  10. /var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Middleware.php line 63
  11. /var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/HandlerStack.php line 75
    GuzzleHttp\Middleware::GuzzleHttp{closure}(“*** sensitive parameters replaced ***”)
  12. /var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php line 331
  13. /var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php line 168
  14. /var/www/html/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php line 187
  15. /var/www/html/nextcloud/lib/private/Http/Client/Client.php line 218
  16. /var/www/html/nextcloud/apps/settings/lib/Controller/CheckSetupController.php line 211
  17. /var/www/html/nextcloud/apps/settings/lib/Controller/CheckSetupController.php line 193
  18. /var/www/html/nextcloud/apps/settings/lib/Controller/CheckSetupController.php line 860
  19. /var/www/html/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 225
  20. /var/www/html/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 133
  21. /var/www/html/nextcloud/lib/private/AppFramework/App.php line 172
  22. /var/www/html/nextcloud/lib/private/Route/Router.php line 298
  23. /var/www/html/nextcloud/lib/base.php line 1030
  24. /var/www/html/nextcloud/index.php line 36

GET /index.php/settings/ajax/checksetup
from by admin at 2023-02-09T18:54:15+00:00

ummm… first of all, welcome to community-forum of NC!

well… have you checked if your server is able to make general internet connections.
then: have you tried pinging nextcloud.com?
and: how are you hosting your instance?
update: did you try downloading update directly and do the backup manually? (pls refer to manual to find out how exactly)
maybe your webupdater is disabled? check config.php for it.

further on it would have been nice if you would have put out more details about the problematic system, initially…

Thanks for the reply. I have confirmed that I can ping many domains and services, just not nextcloud.com for some reason.

xxxxxx@xxxxxx:~$ ping www.microsoft.com
PING e13678.dscb.akamaiedge.net ( 56(84) bytes of data.
64 bytes from a23-35-75-28.deploy.static.akamaitechnologies.com ( icmp_seq=1 ttl=58 time=4.02 ms
64 bytes from a23-35-75-28.deploy.static.akamaitechnologies.com ( icmp_seq=2 ttl=58 time=3.99 ms
--- e13678.dscb.akamaiedge.net ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1002ms
rtt min/avg/max/mdev = 3.994/4.006/4.018/0.012 ms

xxxxxx@xxxxxx:~$ ping google.com
PING google.com ( 56(84) bytes of data.
64 bytes from ord38s42-in-f14.1e100.net ( icmp_seq=1 ttl=118 time=4.18 ms
64 bytes from mia09s16-in-f14.1e100.net ( icmp_seq=2 ttl=118 time=4.08 ms
--- google.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/max/mdev = 4.082/4.130/4.178/0.048 ms

xxxxxx@xxxxxx:~$ ping nextcloud.com
PING nextcloud.com ( 56(84) bytes of data.
--- nextcloud.com ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2053ms

Also confirmed that nslookup had no issues getting to nextcloud.com:

xxxxxx@xxxxxx:~$ nslookup
> nextcloud.com

Non-authoritative answer:
Name:   nextcloud.com
Name:   nextcloud.com
Address: 2a01:4f9:2b:29dc::155
> exit
xxxxxx@xxxxxx:~$ resolvectl status | grep -i "DNS Serve"
Current DNS Server:
       DNS Servers:

I am hosting the instance myself in a VMware environment. I haven’t tried to directly update the server yet because I was hoping this was something I could fix so I could perform the updates the “easy way” as I have been used to on my previous systems.
I also checked the config.php file and I don’t see anything in there about the webupdater. I added the additional two lines that were missing from my config.php but that didn’t make any difference.

'updatechecker' => true,
'updater.server.url' => 'https://updates.nextcloud.com/updater_server/',

Thanks again for the help so far.