Authorization required for anonymous upload

Hi there,

I´ve set up nextcloud for the first time and almost everything went very well. Now I´ve got one serious problem:

As we want to use nextcloud as a upload server for our customers I wanted to achieve the following:

A project manager of our company gets a login - he creates a directory for uploads and then shares the link (maybe with a time limit/ date set). The customer then opens this link and uploads the necessary files.

Now to my problem:

When I want to open the shared link I get some htaccess authorization mask but I don´t know how to solve this -.- I don´t think, that an authorization is good for some kind of “anonymous” upload, we don´t want our customers tu authenticate (as the links are unique, I think…).


Ubuntu 16.04 virtual machine
Apache 2.4.18
Nextcloud 9.0.52
MySQL 5.7

The data directory is in /opt/nextcloud/data (www-data:www-data). I didn´t change anything else like htaccess file.


<VirtualHost *:80>
ServerName transfer.xxxxxxxx.intern
ServerAdmin xxxxxxx

DocumentRoot /var/www/nextcloud/

ProxyPassMatch ^/(.*\.php(/.*)?)$ unix:/run/php/php7.0-fpm.sock|fcgi://localhost/var/www/nextcloud/

ErrorLog ${APACHE_LOG_DIR}/transfer.xxxxxxx.intern/error.log
CustomLog ${APACHE_LOG_DIR}/transfer.xxxxxxx.intern/access.log combined

<Directory /var/www/nextcloud/>
	Options +FollowSymlinks
	AllowOverride All

	<IfModule mod_dav.c>
		Dav off

	SetEnv HOME /var/www/nextcloud
	SetEnv HTTP_HOME /var/www/nextcloud
	Satisfy Any


Anyone any ideas?

Best regards

Not sure why, but your instance is not adding the Authorization: Basic <share token> header.
That seems to be the problem.

Switching to normal mod_php fixed the issue, which brought me to the following:

Thanks to nickvergessen - now it works - switched back from fpm to apache2 handler.