Authentication problems on cPanel shared hosting

I’m having certain issues when using Nextcloud, i managed to install it via Softaculous and everything is OK and i can login. However, after i tried sharing a file via url, got this error which i can’t login to, and i don’t know why it’s appearing as i didn’t choose use password for sharing. Doing a console inspect it seems to be originating from and i’m unable to visit that as it asks me for username and password (the same as before). Any ideas what i can do here?
This seems to be happening only on shared folders, as videos and images seem to work fine.
I’m also unable to use any webdav client to connect as it gives "401 Unauthorized"
Also i’m using PHP 5.4

I currently don’t have that set up, but when i press cancel it outputs this
This is a fresh installation of NextCloud.
Host says that webdav is enabled on the server and they’re not putting any restrictions.

Attempted switching over to PHP 7.1, didn’t fix the issue.

NextCloud official app can’t connect to webdav either.

PHP 7.1 on NC 11 is experimental. Please use php 5.6 or php 7.0.

webdav is provided by the Nextcloud code, the webdav-module of apache must be turned off. Compare with the recommended apache settings:

To realize this in cPanel and other environments can be more challenging than doing it on a bare server.

Hi, these are the only things i can activate on the panel.
So basically i’m stuck without webdav now?

The list of required and recommended php modules can be found in the documentation:

Still getting 401 unauthorized when attempting to connect to Webdav
Am i doing something wrong?
Also this is still occurring when trying to download files

have you set AllowOverride All like in the example config? Can you try the shared id as username and an empty password? Does it work for a password-protected share (share-id as user, password as password)? Please check you webserver logfiles as well if there are any code issues or configuration problems.

Hi, i’m not sure what you mean, can you please explain, not very advanced with this stuff.