Authentication failure despite correct admin password

Nextcloud version: 23.0.0
(Host Machine) Operating system and version: Ubuntu 20.04
Apache or nginx version: Apache/2.4.41 (Ubuntu)
PHP version: PHP 7.4.3

The issue you are facing: I’ve been using Nextcloud merrily for a while now, with no problems whatsoever. Today, after completing installation of a new OS on my new device I installed Nextcloud desktop client through Yay (the device runs arch with Yay AUR helper) and tried to log in. Only to receive an error like this:

There was an error accessing the "token" endpoint: Error transferring - server replied: Method Not Allowed

so I went on to my Nextcloud dashboard (which I can still access on my old device) and logged in completely fine. Although, when I try to visit the domain on a new device that I’ve never logged on to my Nextcloud instance before, I am stuck in a login loop despite entering the correct password.
Naturally, I also tried resetting the admin password using
sudo -u www-data php /var/www/nextcloud/occ user:resetpassword admin and while the command was successful, it did not allow me to create a new user using my admin credentials or log in using the new and changed password.

Is this the first time you’ve seen this error? : Yes

Steps to replicate it: N/A

The output of your Nextcloud log in Admin > Logging:

The output of your config.php :

$CONFIG = array (
  'instanceid' => 'redacted',
  'passwordsalt' => 'redacted',
  'secret' => 'redacted',
  'trusted_domains' => 
  array (
    0 => '',
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwriteprotocol' => 'https',
  'overwrite.cli.url' => '',
  '.htaccess.RewriteBase' => '/',
  'htaccess.IgnoreFrontController' => true,
  'dbname' => 'nextcloud',
  'dbhost' => 'redacted',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'redacted',
  'dbpassword' => 'redacted',
  'installed' => true,
  'maintenance' => false,
  'app_install_overwrite' => 
  array (
    0 => 'files_mindmap',
    1 => 'admin_notifications',

The output of your Apache log: (This is probably relevant)