Audio Player 2.13.1 don't recognizes audio file during the scan

Audio player worked fine on Nextcloud 19.0.0.
I accidentally deleted the playlist.
From that moment it no longer recognizes the same audio files in the default directory and the scan does not proceed.
Searching “for audio files in:” to the directory with .mp3’s files, the response is “Here there is no file”.
I uninstalled and reinstalled the app with the latest version, but nothing changes.
Thanks in advance for the help.

Maybe @Rello has any idea for you?

need some input here:

  • with playlist you mean “Reset Ligrary” from the Settings menu?
  • when you press “Scan for audio files”, what is the result? something like that below?

I am not sure what you mean by “for audio files in:” / “Here there is no file”.
There are no texts in Audio Player like that. let me know via screenshots if possible

Bildschirmfoto 2021-01-03 um 11.40.48

1 Like


I’m afraid I’ve directly deleted the files listed in the play list under the navigation bar of the song being played.




After reading your message saying “Reset Library” I went to the trash and found an “Audios” directory.
I restored it.
It has been restored to the root directory.
Is this your right place? I do not remember.

Thanks again!


first you need to sort out whatever went wrong with your files.
AP can only see what files is seeing.
screenshot 2 is ok - because the filepicker will only show folders. you need to pic the music folder if you have one.

then go over to AP -> Reset Library -> Scan for Audio Files

Hi Rello!

  1. I have a directory called “music” with several subdirectories that contain the music files; Into the AP --> Settings I chose this directory “music”;
  2. Into the AP --> Settings I did “Reset Library”;
  3. I launched Scan for Audio Files.

The progress bar has stood still for over 2 hours and found nothing.
I tried to change directory by selecting a directory with audio files (.mp3, wav etc) with the same result …


can you try to scan from the console?

occ audioplayer:scan user -vv

Hi Rello!

My Nextcloud directory is installed on a remote Linux server.
I don’t know how to activate console command line.

by https?

I search the way on manuals.

Thanks again!

Do you have ssh access?

Or does your hoster has any function to execute commands? Most of them have.