Attempt to add nginx reverse proxy broke Nextcloud

I have a personal nextcloud install with snapraid on Ubuntu-server, which was running fine for about a month. I was trying to add Matterbridge to my server as well, so I tried setting up an Nginx reverse proxy, but after following this tutorial to do so, I realized my name provider (No-IP) doesn’t allow A-names for free.
So to undo it, I set Nextcloud back to 80 and 443 with the same commands, and uncommented the 000-default.conf while removing the additions from the video, and removing http and http_proxy as they were not enabled before trying this. This made Nextcloud inaccessible through home or the internet, whereas when the proxy was setup, http over home worked. Connection was refused from every interface.
I tried a2enmod ssl which brought me to invalid SSL protocol and the default apache2 page (https and http).
A port scan reveals 443 is not open on the machine, and after reinstalling nextcloud and apache2, I still cannot access nextcloud from anywhere. I have no clue where the issue is coming from.

Nextcloud version:
Operating system and version: 18.04
Apache or nginx version: Apache2, 2.4.29
PHP version: 7.2.24

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!): Since it was reinstalled, the config was reset, but my domain name was in the trusted domains array, and it worked on http and https before this attempt.

The output of your Apache/nginx/system log in /var/log/____:

● apache2.service - The Apache HTTP Server
   Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
  Drop-In: /lib/systemd/system/apache2.service.d
   Active: active (running) since Thu 2020-05-28 01:21:22 UTC; 33min ago
 Main PID: 6656 (apache2)
    Tasks: 55 (limit: 4915)
   CGroup: /system.slice/apache2.service
           ├─6656 /usr/sbin/apache2 -k start
           ├─6657 /usr/sbin/apache2 -k start
           └─6658 /usr/sbin/apache2 -k start

May 28 01:21:22 lcars-5201 systemd[1]: Starting The Apache HTTP Server...
May 28 01:21:22 lcars-5201 apachectl[6641]: AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using Set the 'ServerName' d
May 28 01:21:22 lcars-5201 systemd[1]: Started The Apache HTTP Server.

There is nothing on port 443, I don’t know why it doesn’t show up on port scan anymore. Docker and deluge still work fine, likely bc they aren’t using apache2, which seems to have messed everything up.

Hello @Aririi
what is your apache config?

I’m not sure where I would find that, but the only file I modified was undone.
At the moment, I am trying to uninstall apache2 and nextcloud, and just reinstall nextcloud.

EDIT: Doing so yields no change, Nextcloud is inaccessible with a standard snap install.
EDIT 2: Turns out that is false, trying to migrate my existing database into the new install now.

So I managed to get just Nextcloud working, and was able to rescan my admin data, but I can’t make my old users or get Nextcloud to look at it.

Looks like I need my old mySQL password and salt, but I didn’t back that up… Anyways to restore all the user data?

Without db-dump - no.
Create them anew and let them do a new sync from the client.