Attaching NAS - External Storage Visable, But Not Accessable


This is my first time posting here and hoping that anyone can help me or point me to the right direction.

I just installed NC using dietpi VMx86 version, I am currently trying to figure out how to set everything up before I do it on my actual raspberry pi. I also have a QNAP NAS that’s on the same network. In the dietpi VM I am able to mount the NAS shared folder just fine and create new folders/files through the dietpi terminal.

I then go into NC to download the external storage app to try to attach my NAS folder using the local option and it seems to work just fine.

I then go the external storage on the user side of the settings and click on the check mark. However, I get an error but every time I click on the red error symbol it goes green. (Can anyone explain as to why that is?)

Finally I go to my external storage option at the home page and see the folder, yet every time I select it, it bring me back to the home page with a weird glitch as seen below where there seems to be double/copies of the .jpg images and don’t see any of my folders/files that are associated with that shared folder.

Could someone tell me what I’m doing wrong, could it be because I’m doing everything off a VM and not the physical raspberry pi?

I’ve also tried the following commands to see if it was a permission issue but no luck:

chown -R www-data:www-data /mnt/NAS453Be/
chown -R 0750 /mnt/NAS453Be/

The NC that was installed is 17.0.1; I determined this by doing
cat /var/www/nextcloud/version.php

Thank you in advance for your time :slight_smile:

Please test the local storage with the nextcloud folder like


Does this work?

Please use the following commands without / at the end and other permissions.

chown -R www-data:www-data /mnt/NAS453Be
chown -R 755 /mnt/NAS453Be


On my system “data” is 770.
Perhaps test
chown -R 770 /mnt/NAS453Be
chown -R 777 /mnt/NAS453Be

Thanks for the replay,

The location of the nextcloud folder is:

I tired the following command but it did not work, it still appears in nextcloud but cant actually access into it.
chown -R 777 /mnt/NAS453Be

I wanted to double check the prevliges by entering;
ls -al /mnt/
and noticed that it still says dietpi instead of www-data, is that fine or should it have actually changed to www-data?

Hello to anyone else who might want to use Dietpi to install Nextcloud and might run into issues linking the external storage with it.

I was able to figure out what was the issue; long story short it was how I was linking the NAS folder in the /etc/fstab file. I was assigning the user id and group id with dietpi and not www-data.

I was able to find the nextcloud folder in /mnt/dietpi_userdata/nextcloud

I created a new directory in /mnt/dietpi_userdata to then mount the NAS folder. I then edited the fstab file for example:

(Note: TS453 is the host name that represent my NAS’s IP address, so enter IP address of whatever your trying to use SMB)

//TS453/Public /mnt/dietpi_userdata/NAS-Public username={username},password={password},iocharset=utf8,uid=www-data,gid=www-data,file_mode=0770,dir_mode=0770,vers=3.1.1,_netdev,nofail,noauto,x-systemd.automount

Now if you are not doing it on a Raspberry Pi or similar, I noticed that editing the /etc/fstab file like the following below worked well:

//TS453/Public /mnt/dietpi_userdata/NAS-Public cifs username={username},password={password},iocharset=utf8,uid={user_ID},gid={group_ID},file_mode=0770,dir_mode=0770 0 0

Hope this was helpful to whoever stumbles upon it.