ARM / 32-bit / open_basedir

Just came across this warning when attempting to run Nextcloud 10 on a Raspberry Pi 2:

It seems that this Nextcloud instance is running on a 32-bit PHP environment and the open_basedir has been configured in php.ini. This will lead to problems with files over 4 GB and is highly discouraged.
-> Please remove the open_basedir setting within your php.ini or switch to 64-bit PHP.

I don’t really want to use >4GB files on a RPi. But I’d also like to keep open_basedir for security reasons. What can I do to get rid of this warnings?

Then I would set the post_max_size and upload_max_filesize of your php-config to 4G or less.