appstoreFetcher error in OVH shared hosting


I have a Nextcloud instance in a OVH Shared Hosting. I’ve made a new installation and with Nextcloud 12.03 the logging page shows the following error:

Error appstoreFetcher GuzzleHttp\Exception\ConnectException: cURL error 35: error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure

Is there anything that I can do?

Thanks in advance

Ask your host to update your serverside certificates

I experienced the same error when installing the 12.04 version. Does SSL certificates generation resolve the problem ?


Same error here…
did anyone found a way to get trough this error ?
For me it makes the updater and the app store unusable…

You can’t solve it yourself, you must update the certificates on your system (which only the provider can). As a workaround, you could download the apps manually from the app store and put them in the apps folder.

If you are on shared hosting as tflidd already said it there is not much you can do but only your hosting provider can.

We did exoperience the very same problem with Ubuntu 16.04 on a root server though. The culprit was Curl 7.47.0 which ships with Ubuntu 16.04. It doesn’t play nicely with Travis used by Nextcloud 12 upwards but produced that infamous cURL error 35 which makes the updater and the app store unusable. This happened with all our servers running Ubuntu 16.04, Apache 2.4.x and PHP 7.1.x.

Updating Curl to 7.52.1 through Kevin Kelley’s PPA at solved the problem. Note that you have to reinstall Apache and PHP after you have updated Curl to make them link to the new libraries.

Well, I have Ubuntu 16.04 with PHP 7.0 and Apache 2.4 running and no problems with Curl 7.47 regarding any update from all releases of Nextcloud 12 or 13 or any app installation. Maybe it is related to a PHP version not supplied by the distribution (PHP 7.1)?

That is correct: PHP 7.1 was compiled from source.