Apps page isn't loading

Hello guys,

as i said above already, the apps page isnt loading at all. The circle runs and runs and runs. The installation is fresh and everything worked smoothly so far. Im sitting behind a proxy, i already set the variables for that in /etc/environment as well as in /etc/bash.bashrc, also manual insertions via $export http_proxy were done.

I can access everything inside without a problem, just the app’s page doesnt load.

After looking into the nextcloud.log ive found that there is something trying to do a cURL directly to but it fails with "cURL Error 7: Failed to connect to port80: Connection timed out "

I really dont know how to fix this unfortunately.

If you need any specific kind of logs/configs please tell me and i will upload them asap.

EDIT: Is this maybe more helpful?

I’ve found the solution by myself.

For anyone facing the same problem:

i needed to type something in the /var/www/nextcloud/config/config.php which was
’proxy’ => ‘proxyhost:port/’,
‘proxyuserpwd’ => ‘Username:Password’,

Everything worked after i’ve made these entries.