Apps.nextcloud unreachable. Cannot install apps

Hello.

I’m new to linux and nextcloud.

From the command prompt
Ubuntu 18.04.4 LTS with graph interface
mariaDB 10.4
Apache HTTP 2.4
PHP runtime 7.3 and the required addons

I followed the official guide
https://docs.nextcloud.com/server/18/admin_manual/installation/system_requirements.html
https://docs.nextcloud.com/server/18/admin_manual/installation/source_installation.html
https://docs.nextcloud.com/server/18/admin_manual/installation/example_ubuntu.html

Then I downloaded the official nextcloud 18 zip file. Tried extracting it and putting it in place inside the Apache root as recommended. not much luck.

so then i followed this guide:

installed nextcloud 18 through command prompt from github. 660mb.

I am able to acces nextcloud 18 as admin on localhost.


The Problem

None of my devices are able to acces apps anymore.
Therefore nexcloud 18 cannot show apps to install.
I am typing this from the ubuntu server.
help is accessible to me.

Disconnecting my phone from wifi; reconnecting to mobile broadband shows a working apps website on that phone.

Somehow none of the devices on my home internet are able to acces apps

Shutting down mariaDB and ApacheHTTPS does not help.


Ideas please.
Thank you

Somehow none of the devices on my home internet are able to acces apps

Do you mean none of your devices can access any internet apps on the home network or Just the Nextcloud app you just tried to install?

If it’s the former, those instructions would not have created such a result. Um restart your router then contact your ISP?

If it’s the later the instructions should work except use stable18 instead of stable13. Also php7.2 is now standard on Ubuntu 18.04 you don’t need to add the ppa. Also you either you need to own the domain OR if you’re just setting up for local testing you need to edit /etc/hosts file. For example.com to work on just the local device you would add a line: 127.0.0.1 example.com.

To access on your home network a few more steps are required.

If you’re trying to learn Linux some basics wouldn’t hurt including LAMP stack and basic networking stuff - I think linuxacademy.com has some free courses. Also check out LXC if on Ubuntu - great for setting up dev servers just to play and learn with.

Finally for easier installs, check out the Linux snap package (I use myself) or for a guided server install https://github.com/nextcloud/vm (haven’t tried myself).

Can you please retry it again, because there was a server outage this afternoon which has been solved in the meantime.