App "Face Recognition" cannot be installed (pdlib is not available)

Hi folks,

I’m a bit new to Nextcloud and running some tests. My install is running on the VM from Hansson IT. I’m trying to install the Face Recognition app, and getting the message below. Any ideas on how to resolve this?

An error occured during the request. Unable to proceed.
App “Face Recognition” cannot be installed because the following dependencies are not fulfilled: The library pdlib is not available.:heavy_multiplication_x:

If something is missing, you need to install it :wink: Install and activate the php7.x-pdlib module on your server which should also install the underlying pdlib library itself.

Ok, I guess I really need to spend some time learning Linux better. I’m in the process of migrating off Big Tech, so, no more MS Windows. I’ll have to research how to install pdlib.

Hi @DadOfRCA,

If your VM is running Ubuntu focal (20.04), those instructions should work for you:

I hope it helps!

1 Like

Thank you.
Yes, this helps. I’ll play around with this.

I’m having the same issue but now I’m getting “permission denied” when I go to run:

`echo "deb https://repo.delellis.com.ar focal focal" > /etc/apt/sources.list.d/20-pdlib.list`

I downloaded the VM from https://www.hanssonit.se/nextcloud-vm and imported into VMWare. I ran the first setup menu and have NextCloud running but can’t install App “Face Recognition because of this error.

Hey @GetCart3r if you are still on NC20, you can try this script which should make the whole install process much easier :slight_smile:

THanks for the quick reply @szaimen

Sadly this is where my coding/Linux experience is lacking. I went to the link but now sure what I need to do.

Also this issue is on both a dedicated laptop that’s running NextCloud and the VM that I downloaded today. Laptop is v.21 and I thought the VM was21 after updates.

Unfortunately, the facerecognition app isn’t compatible with NC21, yet. So the installation of the app will fail.
If you still had NC20 installed, it would be a simple:

wget https://raw.githubusercontent.com/nextcloud/vm/enh/facerecognition/apps/face-recognition.sh
sudo bash face-recognition.sh

Ahh ok thanks! So the latest VM must also be 21. I will see about downloading an older VM with 20 and give it a try.

1 Like

I’m now at a total loss. I’m running version 20 VM and still when I run either of the commands all I get is "permission denied”

Which commands did you run?

Thanks @szaimen finally got it installed. I was getting errors but then selected to uninstall Face Recognition then reinstall and that cleaned it up.

Not sure how long it will take but will see what happens over night.

Thanks!

1 Like